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1 Introduction
The Research and User Support for Sentinel core products (RUS) service provides a free and open
scalable platform in a powerful computing environment, hosting a suite of open source toolboxes
pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel
satellites constellation.
A series of four initial deadly wildfires erupted
across central Portugal in the afternoon of 17
June 2017 within minutes of each other,
resulting in at least 64 deaths and 204 injured.
An intense heat wave preceded the fires, with
many areas of Portugal, seeing temperatures
in excess of 40 °C (104 °F).
During the night of 17–18 June, a total of 156
fires erupted across the country, particularly in
mountainous areas 200 km (120 mi) northnortheast of Lisbon. The fires began in the
Portugal wildfires June 2017 Credits: www.theguardian.com [June
18, 2017]
Pedrógão
Grande
municipality
before
spreading to others and causing a firestorm. A total of 44,969 hectares of land was burned by the
fires as of 20 June. Of this, 29,693 hectares (73,370 acres) was in the Pedrógão Grande area.
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Training

Approximate duration of this training session is two hours.
The Training Code for this tutorial is HAZA02. If you wish to practice the exercise described below
within the RUS Virtual Environment, register on the RUS portal (rus-copernicus.eu) and open a
User Service request from Your RUS service > Your dashboard.
2.1
•

Data used
Two Sentinel-2A Level 2A tiles (Tile ID: T29TNE) acquired between on June 4, 2017 (before the
main event) and July 4, 2017 (after the main event).
[downloadable @ https://scihub.copernicus.eu/]
S2A_MSIL2A_ 20170604T112121_N0205_R037_T29TNE_20170604T112755.zip
S2A_MSIL2A_ 20170704T112111_N0205_R037_T29TNE_20170604T112431.zip

2.2

Software in RUS environment

Internet browser, SNAP + Sentinel-2 Toolbox, QGIS, (Extra steps: Sen2Cor, Google Earth)
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3
3.1

Step by step
Data download – ESA SciHUB

In this step we will download a Sentinel-2 scene from the Copernicus Open Access Hub using the
online interface (Applications -> Network -> Web Browser, or click the link below).
Go to https://scihub.copernicus.eu/

Go to Open HUB, if you do not have an account please register in upper right corner.

After you’ve filled in the registration form you will receive an activation link by e-mail. Once your
account is activated or if you already have an account, log in.
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Switch the rectangle drawing mode to pan mode by clicking on the ‘Pan’ icon in the lower left corner
of the map (Green arrow) and navigate over Portugal (approximate area – blue rectangle).

Switch to drawing mode and draw a search rectangle approximately as indicated below. Open the
search menu (red arrow) and specify the following parameters (See

TIP 1):

Sensing period: From 2017/06/04 to 2017/07/04
Check Mission: Sentinel-2
Product Type: S2MSI2Ap
TIP 1: For the Level 2A products we are downloading the atmospheric correction has already been
applied (pre-processing of Level-1C product to a Level-2A is described in section 4.1). Atmospheric
correction using Sen2Cor algorithm is a computationally heavy process and takes approximately 30
minutes per image to be completed depending on your machine. However, since April 2017 the Level2A products have already been generated and are available to download for acquisitions over Europe
(such as this case). If you want to try to run the atmospheric correction (section 4.1) nevertheless, you
can change:
Product Type: S2MSIL1
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In our case the search returns 13 results depending on the exact search area defined. Download the
scenes (pay attention to the tile ID, below in red):
S2A_MSIL2A_ 20170604T112121_N0205_R037_T29TNE_20170604T112755
S2A_MSIL2A_ 20170704T112111_N0205_R037_T29TNE_20170704T112431

Data will be downloaded to /home/rus/Downloads as ZIP archives. Move the archives to:
/shared/Training/HAZA02_BurnedArea_Portugal_TutorialKit/Original
Right click each archive and use Extract Here to unzip the folders.
3.2

SNAP – open and explore data

Launch SNAP (icon on desktop
). When the SNAP window opens click Open product
to /shared/Training/HAZA02_BurnedArea_Portugal_TutorialKit/Original

, navigate

In each folder navigate to *.SAFE folder and open the MTD_MSIL2A.xml file. At the end you will have
both products opened in the Products Explorer pane on the left.
Now, we will look at the products. We could visualize them in true (natural) colours but for
distinguishing the burned areas it is better to use the Near InfraRed (NIR) and Short Wave InfraRed
(SWIR) bands as these provide the best separability (for more explanation, check the graph in
5

NOTE 2). Right click the pre-fire product from 4 June and click Open RGB image window, a new
window will open.
Set:

Red: B12
Green: B11
Blue: B8A

Do the same for the post fire product from 4 July. Now we will have 2 windows opened.

Now go to Navigation pane in the lower left and make sure the cursor
and the views
are
linked. Then, go to Window -> Tile Horizontally. The image appears in the upper left corner of the
view window. Click on the Pan mode on View [2] and zoom in to the burned area – orange-brown
colour. (See
NOTE 1).
NOTE 1: The input product
contains 13 spectral bands
in 3 different spatial
resolutions (The surface
area measured on the
ground and represented by
an individual pixel). When
we open the RGB view all
our input bands have 20 m
resolution, however, the
view is displayed in the full
10 m resolution.

Credits: ESA 2015
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3.3

Creating a cloud mask band

The Sentinel-2 L2-A product conveniently contains vector cloud and cirrus masks, which are created
as a product of the atmospheric correction, however, applying the mask on all bands and full scene
takes some time. We can subset the product but the vector products are lost by that operation. So in
our case to preserve the information we will create a new band containing a cloud mask. This is
currently not possible to do using batch processing so we need to add the cloud_mask band to each
product separately.
Right-click on the first open product from 4 June [1] and click Band Maths. A new window will open.
Set name to: cloud_mask (the name must be the same in both products!!!)
And deselect Virtual (safe expression only, don’t store data)
Then click Edit Expression… and enter the following statement:
if (scl_cloud_medium_proba + scl_cloud_high_proba + scl_thin_cirrus)
< 255 then 0 else 1
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The new band will automatically open in a new view; we can click in the view name tab and drag the
view window to the appropriate RGB view. And in Navigation tab click Zoom All

.

Do the same for the post-fire products (you can copy paste the expression to the Band maths
expression without clicking on Edit Expression. Don’t forget to change the product number in the
expression).

3.4

Pre-processing

As we have seen in the previous step, processing the data one by one would be very time consuming
and inconvenient. However, we can use the Batch Processing tool available in SNAP to process all
images at the same time.
To use the tool we first need to define the process we want to apply and all its steps. We can do this
using the GraphBuilder tool. The nice thing about the GraphBuilder is also that no intermediate
product will be physically saved, only the end product which saves valuable disk space.
So let’s build our graph. Go to Tools -> GraphBuilder.
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At the moment the graph only has two operators: Read (to read the input) and Write (to write the
output).
The 13 bands in Sentinel-2 products do not all have same resolution (therefore size) as mentioned in
NOTE 1. Many operators do not support products with bands of different sizes so first we need to
resample the bands to equal resolution. To add the operator right-click the white space between
existing operators and go to Add -> Raster -> Geometric -> Resample
A new operator rectangle appears in our graph and new tab appears below. Now connect the new
Resample operator with the Read operator by clicking to the right side of the Read operator and
dragging the red arrow towards the Resample operator.

Next step will be to subset the images to the area of interest, we do this by right-clicking the white
space somewhere left of the resample operator and going to Add -> Raster -> Geometric -> Subset.
Connect the Subset operator with the Resample operator.
Now, we will add the BandMath operator from Add -> Raster -> BandMaths connect it to the Subset
operator. Last, we add BandMerge operator from Add -> Raster -> BandMerge. Connect both, the
Subset operator and the BandMaths operator, to the BandMerge operator. And then connect the
BandMerge operator with the Write operator.

At the moment, do not change anything in the parameter tabs and save the graph as
Graph_process.xml in /shared/Training/HAZA02_BurnedArea_Portugal_TutorialKit/Processing by
clicking Save at the bottom of the window.
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In the Product Explorer, we select (highlight) the product [1] (4 June 2017). Now we can close the
GraphBuilder window and open the Batch Processing tool (Tools -> Batch Processing).
Now, we will add both opened products by clicking Add Opened on the upper right (second from
top). And click refresh. Unselect the Keep source product name. Then we click Load Graph at the
bottom of the window and navigate to our saved graph and open it. We see that new tabs have
appeared at the top of window corresponding to our operators.

Now, let’s set the parameters. In Resample tab we set:
Define size of resampled product: By reference band from source product: B2 (we will resample all
the bands to 10m resolution). And at the bottom set Upsampling method: Bilinear

In the Subset tab we select bands: B3, B8, B12 and cloud_mask (to select multiple hold Ctrl). And set:
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Pixel coordinates to: X: 5400

Y: 4800

Width: 5580

Height: 6180

Next, we set the expression for the calculation of Normalized Burn Ratio (NBR). (See
the BandMaths tab set:
Target band: NBR
No-Data Value: NaN
Expression: (B8 – B12)/(B8 + B12)

NOTE 2) In

NOTE 2: The most commonly used metrics for burned area and burn severity mapping, derived from
satellite data, is the normalized burn ratio (NBR).
𝑁𝐵𝑅 =

𝑁𝐼𝑅 − 𝑆𝑊𝐼𝑅
𝑁𝐼𝑅 + 𝑆𝑊𝐼𝑅

Healthy vegetation has very high near-infrared reflectance and low reflectance in the shortwave
infrared portion of the spectrum. Burned areas on the other hand have relatively low reflectance in the
near-infrared and high reflectance in the shortwave infrared band. A high NBR value generally indicates
healthy vegetation while a low value indicates bare ground and recently burned areas.

Credits: U.S. Forest service
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Leave the defaults in the BandMerge tab.

In the Write tab check that the name contains 20170604 but do not change anything. Set the output
directory: /shared/Training/HAZA02_BurnedArea_Portugal_TutorialKit/Processing

And let’s click Run. This might take approximately 7 minutes depending on your machine.
Now, you should have two new products in the Product Explorer. Let’s have a look at the subset
products. For that, close all the view windows and Expand product [3]. In Bands double click the NBR
band. Now do the same for product [4]. Go to Window -> Tile Horizontally and then in Navigation
tab click Zoom All

.
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Close all view windows.
3.5

Collocation

Now we will merge the two pre-processed products so we can easily calculate the change in the preand post-fire NBR values. Go to Raster -> Geometric Operations -> Collocation.
In Source Products set product [3] as Master and product [4] as Slave.
In Target Products set Name: S2A_20170604_20170704

In Renaming of Source Product Components change to ${ORIGINAL_NAME}_June and
${ORIGINAL_NAME}_July.
Set output directory to /shared/Training/HAZA02_BurnedArea_Portugal_TutorialKit/Processing. Click
Run. A new product [5] has been created in Product Explorer.
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3.6

Water and cloud mask

Water bodies can show similar NBR difference in certain circumstances, therefore, it is necessary to
mask them out. We also need to mask out clouds occurring in either input image. For this purpose,
we will create a single combined water and cloud mask. To detect the water bodies we will use the
Normalized Difference Water Index - NDWI (See
NOTE 3).2
2

NOTE 3: The Normalized Difference Water Index (NDWI) proposed by McFeeters is designed to:
maximize the reflectance of the water body in the green band; minimize the reflectance of water body
in the NIR band. McFeeters’s NDWI is calculated as:
𝑁𝐷𝑊𝐼 =

𝐺𝑟𝑒𝑒𝑛 − 𝑁𝐼𝑅
𝐵3 − 𝐵8
=
𝐺𝑟𝑒𝑒𝑛 + 𝑁𝐼𝑅
𝐵3 + 𝐵8

Right click on the newly created stacked product [5], select BandMaths and set:
Target band: cloud_water_mask
Expression: if (cloud_mask_June > 0 or cloud_mask_July > 0 or ((B3_June
– B8_June)/ (B3_June + B8_June))>= 0.0) then 1 else 0
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3.7

Burned areas and burn severity

To identify recently burned areas and differentiate them from bare soil and other non-vegetated
areas the difference between pre-fire and post-fire NBR, the delta Normalized Burn Ratio (dNBR) is
frequently used.

𝑑𝑁𝐵𝑅 = 𝑁𝐵𝑅𝑝𝑟𝑒−𝑓𝑖𝑟𝑒 − 𝑁𝐵𝑅𝑝𝑜𝑠𝑡−𝑓𝑖𝑟𝑒

However, the dNBR is an absolute difference which can present problems in areas with low pre-fire
vegetation cover, where the absolute change between pre-fire and post-fire NBR will be small. In
such cases the relativized version of burn severity is advantageous. In this tutorial we will use the
Relativized Burn Ratio (RBR)3.

𝑁𝐵𝑅𝑝𝑟𝑒−𝑓𝑖𝑟𝑒 − 𝑁𝐵𝑅𝑝𝑜𝑠𝑡−𝑓𝑖𝑟𝑒
𝑑𝑁𝐵𝑅
𝑅𝐵𝑅 = (
)= (
)
(𝑁𝐵𝑅𝑝𝑟𝑒−𝑓𝑖𝑟𝑒 + 1.001)
(𝑁𝐵𝑅𝑝𝑟𝑒−𝑓𝑖𝑟𝑒 + 1.001)

In this step we will also apply the cloud and water mask we have created. Again, we will create new
band by going to BandMaths in product [5] and we set:
Target band: RBR
Expression: if cloud_water_mask == 0 then ((NBR_June – NBR_July)/(NBR_June +
1.001)) else NaN

Deselect Virtual (save expression only, don’t store data) – we want the band to be stored!
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The burned pixels appear much brighter as the change in between pre- and post-fire values is much
higher. Now let’s create another new band that will only contain burned areas. We will set the
threshold for pixel to be classified as burned to > 0.27. Right click product [5] and for to BandMaths
again. Set:
Target band: RBR_
No-Data Value: NaN
Expression: if RBR > 0.27 then RBR else NaN
Deselect Virtual (save expression only, don’t store data) – we want the band to be stored!
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3.8

Export as GeoTIFF

Close all view windows. In Product Explorer select (highlight) product [5], go to File -> Export ->
GeoTiff (NOT! Geotiff/Big Tiff). In the dialog that opens click Subset -> Band Subset (second tab) and
select only bands RBR and RBR_ click Ok and save the file as S2A_20170604_2017_0704_RBR.tif to
the Processing folder. In the dialog that appears (No Flag Dataset Selected) click No.
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Now we can import the image to another GIS/ Remote sensing software for further processing or
map creation. In this tutorial we will use QGIS.
3.9

Visualization

Go to Application -> Processing -> QGIS Desktop (or use the desktop icon). Click on the Add Raster
Layer button located in the left panel ( ), navigate to:
/shared/Training/HAZA02_BurnedArea_Portugal_TutorialKit/Processing
select the S2A_20170604_2017_0704_RBR.tif and click Open.

We can change the colour scheme to classes proposed by the United States Geological Survey (USGS)
to interpret the burn severity (See
NOTE 4). 4
NOTE 4: The United States Geological Survey (USGS) proposed a classification table to interpret the burn
4
severity (dNBR), which can be seen in the table below . In our data the lowest value is -0.08,
demonstrating that there were no values related to detectable regrowth. The large number of
ambiguous pixels (yellow) is caused by the one month difference between our pre- and post-fire images.
Due to the severe drought the vegetation likely degraded significantly between these two dates
producing similar NBR difference as low severity burn.
While we are using RBR and not dNBR, we will apply the same classes as defined below for visualization.
It is generally difficult to derive the burn severity without ground data to relate the values to.

Credits: UN-SPYDER Knowledge Portal

We will use a predefined file to import the colour pallete. Right-click on the opened raster-layer in
the Layers Panel (lower left) and go to Properties. In the Style tab set:
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Render type: Singleband pseudocolor
Interpolation: Discrete
Band: Band 1 (BRB)
Then click
Load colour map from file to import predefined colour map. Navigate to the Auxdata
folder and open Colour_palete_RBR.txt. Click OK.

To visualize only the Moderate to High severity areas go to Properties again and in Style tab set band
to Band 2. You will have to import the colour map again the same way as we have done for Band 1.
Click OK.
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Finally, we can add a base-map to link our water masks to GIS data. Click on Web -> OpenLayers
plugin -> Google Maps -> Google Satellite (See
NOTE 5). Then in the Layer Panel click on the
Google Satellite layer and drag it below our raster layer.
NOTE 5: In case the OpenLayers plugin is not installed, click on Plugins -> Manage and Install Plugins.
Select the ‘All’ tab on the right side panel and write “OpenLayers plugin” on the search box. Select the
plugin on the list and click ‘Install Plugin’. Restart QGIS to finalize the installation.

To download the results to your local computer see section 4.2 Downloading the outputs from VM.

THANK YOU FOR FOLLOWING THE EXERCISE!
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4

Extra steps

4.1

Atmospheric correction (

TIP 1)

Solar radiation reflected by the Earth’s surface to satellite sensors is affected by its interaction with
the atmosphere. The objective of applying an atmospheric correction is to determine true surface
(Bottom-Of-Atmosphere, BOA) reflectance values from the Top-Of-Atmosphere (TOA) reflectance
values, by removing atmospheric effects. (See
NOTE 6) Atmospheric correction is especially
important in cases where multi-temporal images are compared and analysed as it is in our case (prefire and post-fire images).1
NOTE 6: The radiance reaching the sensor is a result of following components:
1. Radiation from the sun and, scattered into the field
of view of the sensor by the atmosphere without
reaching the surface.
2. Direct radiation that goes through the atmosphere
without being absorbed or scattered, reaches the
sensor after being reflected by the target pixel.
3. Radiation scattered by the atmosphere into the
target pixel and reflected back towards the sensor.

Credits: Mousivand et al., 2015

4. & 5. Direct or diffuse radiation reflected or scattered by
the surrounding areas into the field of view of the sensor.
This effect is so called “adjacency effect” or “blurring
effect”.
6. Diffuse radiation coming from the adjacent features into
the field of view of the sensor.
7. So-called trapping effect and it is a part of the radiation
reflected from the surface into the air column above the
surface being scattered and ultimately reaches the sensor.

1

In this tutorial we will use the Sen2Cor processor. Sen2Cor is a processor for Sentinel-2 Level 2A
product generation and formatting; it performs the atmospheric, terrain and cirrus correction of TopOf-Atmosphere Level 1C input data. Sen2Cor creates Bottom-Of-Atmosphere, optionally terrain and
cirrus corrected reflectance images; additional, Aerosol Optical Thickness, Water Vapour, Scene
Classification Maps and Quality Indicators for cloud and snow probabilities.
In the I/O Parameters make sure product [1] is selected. In the Processing Parameters tab change the
resolution to 10 m. Click Run …
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Repeat for product [2]. This is rather a time demanding process and requires approximately 30
minutes per image (with 8GB RAM).
The process creates two new Level 2-A product in the .SAFE format in the
/shared/Training/HAZA02_BurnedArea_Portugal_TutorialKit/Original
4.2

Downloading the outputs from VM

Press Ctrl+Alt+Shift. A pop-up window will appear on the left side of the screen. Click on bar below
Devices, the folder structure of your VM will appear. Navigate to your Processing folder and double
click any file you want to download.

4.3

Export as KMZ (Google Earth)

If we want to view the product for example in Google Earth, unfortunately we must first reproject it
to WGS 84 Lat/Lon coordinate system (EPSG 4326), as the KMZ format does not accept other
projections, set colour scheme, export to KMZ format readable by Google Earth and then download
results to our local PC for visualization as the RUS VM does not support Google Earth installation.
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It is time consuming and unnecessary to reproject the whole product [5] therefore we will first apply
band subset. Click on product [5] so it is highlighted and then go to Raster -> Subset. Do not change
anything in the Spatial Subset tab and go to the Band Subset tab. Deselect all the bands except RBR
and RBR_. Click OK.
In the “No Flag dataset selected” dialog click “No”.

Product [6] was created containing only the two selected bands. To reproject from the default
UTM33 projection to Lat/Long we go to Raster -> Geometric Operations -> Reproject. Check that
the new subset [6] is selected as input and the Processing folder is set as the target directory. In the
Projection Parameters tab make sure the Projection is set to Geographic Lat/Lon (WGS84) and click
Run.

Go to Colour Manipulation Tab in the lower left corner and right click the colour bar between
existing sliders – add 2 new sliders. Then go to table and set colours and values as in the table in
NOTE 5.
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To export the KMZ layer, click on the RBR View to activate it and go to File -> Export -> Other -> View
as Google Earth KMZ (only the active band open in the view window will be saved)
Save to the Processing folder as: Burn_severity_20170704.kmz. Now open or activate the BRB_ layer
and export it as well (Burned_area_20170704.kmz)
Download the KMZ files to your laptop following instructions in section 4.2.
Open Google Earth (Applications -> Internet -> Google Earth) if you have in installed. Go to File ->
Open and open the downloaded layers. Both layers will appear as overlays in the Places panel on the
left (activate and deactivate layer and legend) with the name of the original band (not the saved
KMZ).
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5

Further reading and resources

The European Forest Fire Information System (EFFIS) – link
Normalized Burn Ratio by Humbold State University – link
UN-SPYDER Knowledge Portal – Normalized Burn Ratio – link
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