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Introduction

The Research and User Support for Sentinel core products (RUS) service provides a free and open
scalable platform in a powerful computing environment, hosting a suite of open source toolboxes
pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel
satellites constellation. In this tutorial we will employ RUS to identify and map land subsidence in
Mexico City using Sentinel-1 data.
Land subsidence in Mexico City caused
by groundwater overexploitation over
the last century has been more than 9
meters, resulting in damages to
buildings, streets, sidewalks, sewers,
storm water drains and other
infrastructure [1]. Previous studies of
SAR Interferometry using ERS data
showed a maximum subsidence rate
larger than 30 cm/year over parts of the
city [2].
Due to the fact that the city is partially
built on the area of a former lake (Lago
Texcoco), it rests on the heavily
saturated clay which is collapsing due to
the over-extraction of groundwater. Current subsidence rates using Sentinel-1 SAR data approximate
2.5 cm/month [3].
Mexico City’s buildings are seriously leaning due to land
subsidence. Photo credit: JOSH HANER/THE NEW YORK TIMES
(http://www.sciencemag.org)
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Training

Approximate duration of this training session is two hours.
The Training Code for this tutorial is HAZA03. If you wish to practice the exercise described below
within the RUS Virtual Environment, register on the RUS portal and open a User Service request
from Your RUS service → Your dashboard.
2.1
•

Data used
Two Sentinel-1A images acquired on June 6, 2016 and September 10, 2016.
[downloadable @ https://scihub.copernicus.eu/]

S1A_IW_SLC__1SSV_20160606T122537_20160606T122601_011590_011B5B_E555.zip
S1A_IW_SLC__1SSV_20160910T122542_20160910T122606_012990_0148FA_76D7.zip
•

2.2

Auxiliary data stored locally
@ /shared/Training/HAZA03_LandSubsidence_MexicoCity_TutorialKit/AuxData
Software in RUS environment

Internet browser, SNAP + Sentinel-1 Toolbox, (Extra steps: Google Earth)
3

3

Register to RUS Copernicus

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as
a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on
Login/Register in the upper right corner.

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus
Users’ Single Sign On Registration. Click Register.

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the email to activate your account.
You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter
your chosen credentials.
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Upon your first login you will need to enter some details. You must fill all the fields.
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Request a RUS Copernicus Virtual Machine

Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise
or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service →
Your Dashboard.
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that
the appropriate cloud environment can be assigned according to your needs.

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the
appropriate field.

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your
request once you are finished.
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email
with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your
Dashboard and click on Access my Virtual Machine.
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access
your RUS Copernicus Virtual Machine.

This is the remote desktop of your Virtual Machine.
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5.1

Step by step
Data download – ESA SciHUB

In this step we will download two Sentinel-1 scenes from the Copernicus Open Access Hub using the
online interface (Applications → Network → Firefox Web Browser or click the link below).
Go to https://scihub.copernicus.eu/
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Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN
menu in the upper right corner.
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After you have filled in the registration form, you will receive an activation link by e-mail. Once your
account is activated or if you already have an account, “LOGIN”.
Select the “Pan” icon in the lower left corner of the map and navigate over Mexico City.

Switch to “Box” icon and draw a search rectangle approximately as indicated above (approximate
area – blue rectangle). Open the search menu ( ) and specify the following parameters. Press the
search button ( ) after that.
Sensing period: From 2016/06/06 to 2016/06/06
Check Mission: Sentinel-1A
Satellite Platform: S1A_*
Product Type: SLC
Sensor Mode: IW
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In our case the search returns 1 result depending on the exact search area defined. Download the
scene:
S1A_IW_SLC__1SSV_20160606T122537_20160606T122601_011590_011B5B_E555
Repeat the steps for the second image September 10, 2016, by changing accordingly the sensing
period range. Download the scene:
S1A_IW_SLC__1SSV_20160910T122542_20160910T122606_012990_0148FA_76D7
Data will be downloaded to /home/rus/Downloads as zip archives. Move the archives to:
/shared/Training/HAZA03_LandSubsidence_MexicoCity_TutorialKit/Original.
5.2

SNAP – open and explore data

Launch SNAP (icon on desktop ). When SNAP opens, click Open product
, navigate to /shared/
Training/HAZA03_LandSubsidence_MexicoCity_TutorialKit/Original and open the *.zip files.
The opened products will appear in the Product Explorer window on the left. Expand the first image
to the left and then expand Bands. Right-click on the “Intensity_IW3_VV” band and select Open
Image Window to create and visualize the image of the band (or double-click on it). (See
NOTE 1).
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The image appears in the upper left corner of the view window. Repeat the same steps for the
second product. To synchronize the views, go to Navigation tab in the lower left (red arrow) and
make sure the cursor

and the views

NOTE 1: The Interferometric
Wide (IW) swath mode
captures three sub-swaths
using Terrain Observation with
Progressive
Scans
SAR
(TOPSAR). Each sub-swath
image consists of a series of
bursts. The input product
contains 3 IW bands, and 8
bursts. Mexico City is located
on the IW3 sub-swath of the
Sentinel-1 images.

5.3

are linked.

3
4
5

IW3

IW2

IW1

Credits: ESA User Guides for Sentinel-1 SAR

Pre-processing

Since the area of interest is included in 3 bursts of the Sentinel-1 image, there is no need to process
the whole sub-swath with the 8 bursts (See
NOTE 2). The extraction of Sentinel-1 TOPS bursts will
be made per acquisition and per sub-swath. This process will reduce the processing time in the
following processing steps and is recommended when the analysis is focused only over a specific area
and not the complete scene. Go to Radar → Sentinel-1 TOPS → S-1 TOPS Split.

Now, let’s set the parameters. In the source product select the opened image:
S1A_IW_SLC__1SSV_20160606T122537_20160606T122601_011590_011B5B_E555.zip
Then, define the output directory in:
/shared/Training/HAZA03_LandSubsidence_MexicoCity_TutorialKit/Processing.
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In the I/O Parameters tab, leave the default output name for the target product name. The system
inserts automatically the suffix of the split process in order to discriminate the split product from the
original data.

In the Processing Parameters tab, select the following parameters:
Subswath: IW3
Polarisations: VV
Bursts: 3 to 5
In Bursts selection click on the arrows and drag up to the specified number of bursts. Then click RUN.

Repeat the split process for the second Sentinel-1 image using same processing parameters:
S1A_IW_SLC__1SSV_20160910T122542_20160910T122606_012990_0148FA_76D7
NOTE 2: The extraction of bursts in a sub-swath covering the area of interest may differ in Sentinel-1
images acquired on different dates.
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5.4

Graph Builder

Although data processing could follow a manual step-by-step process, Graph Builder tool available in
SNAP allows the automatic processing of the images.

The Graph Builder tool allows the user to assemble graphs from a list of available operators and
connect operator nodes to their sources. Therefore, the processing chain we will follow, will be
represented by a graph and saved as an XML file.
In order to add Graph Builder tool, go to Tools → GraphBuilder.
Initially, the graph has two operators: Read (to read the input) and Write (to write the output) (See
NOTE 3). With right-click on the top panel you can add an operator, while a corresponding tab is
created and added on the bottom panel.
Since pre-processing split process has preceded, in the Read tab select the name of the split product:
S1A_IW_SLC__1SSV_20160606T122537_20160606T122601_011590_011B5B_E555_split.dim.

NOTE 3: In case split process is already applied, input image in the Read tab will be the splitted product
of the Sentinel-1 image.

Before adding the rest operators, delete the Write operator (right-click on it → Delete) to avoid
confusion in the sequence of the graph and we will add it at the end.
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5.5

Co-registration

The first processing step is to apply the orbit files in Sentinel-1 products in order to provide accurate
satellite position and velocity information. To add the operator right-click on the top panel to the
right of the existing operator and go to Add → Radar → Apply-Orbit-File.
A new operator rectangle appears in our graph and a new tab appears below. Now connect the new
Apply-Orbit-File operator with the Read operator by clicking to the right side of the Read operator
and dragging the red arrow towards the Apply-Orbit-File operator.

In the Apply-Orbit File tab select the parameters:
Orbit State Vectors: Sentinel Precise (Auto Download)
Check “Do not fail if new orbit file is not found”

Now, we have to repeat the same steps for the second image. First we need to add a new Read(2)
operator. Right-click and go to Add → Input-Output → Read. In the Read(2) tab, select the split
product:
S1A_IW_SLC__1SSV_20160910T122542_20160910T122606_012990_0148FA_76D7_split.dim
Then, go to Add → Radar → Apply-Orbit-File and select the same parameters as in the first product
and then connect the Apply-Orbit-File(2) to the Read(2) operator.

Next step will be to co-register the two Sentinel-1 images. For this reason the second image (slave)
will be co-registered with respect to the first image (master). Sentinel-1 Back Geocoding operator
co-registers two S-1 split products (master and slave) of the same sub-swath using the orbits of the
two products and a Digital Elevation Model (DEM).
Rght-clicking right of the Apply-Orbit-File operator and go to Add → Radar → Coregistration → S-1
TOPS Coregistration → Back-Geocoding. Connect the Back-Geocoding operator with the ApplyOrbit-File operators.
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In the Back-Geocoding tab use default parameters, but also check “Output Deramp and Demod
Phase” option (See
NOTE 4).
NOTE 4: Deramp and Demod Phase is required when ESD operator follows Back-Geocoding.

In this step, Enhanced Spectral Diversity (ESD) operator follows Back-Geocoding. The ESD approach
exploits the data at the overlapped area of the adjacent bursts, and then performs range and
azimuth correction for every burst. In the same manner, go to Add → Radar → Coregistration → S-1
TOPS Coregistration → Enhanced-Spectral-Diversity and then connect ESD and Back-Geocoding
operators.

In the Enhanced-Spectral-Diversity tab use the default parameters.

5.6

Interferometric Processing

At this stage, we will produce an Interferogram between the interferometric pair (master and slave),
while a coherence image estimation from the stack of the coregistered complex images is included.
To add the Interferogram operator go to Add → Radar → Interferometric → Products →
Interferogram add then connect the Interferogram operator to Enhanced-Spectral-Diversity
operator.
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In the Interferogram tab set the following parameters:
Coherence Range Window Size: 20
Coherence Azimuth Window Size: 5

We continue the processing steps with Sentinel-1 TOPSAR Deburst. We have seen that each subswath image consists of a series of bursts, where each burst has been processed as a separate SLC
image. The individually focused complex burst images are included, in azimuth-time order, into a
single sub-swath image with black-fill demarcation in between. There is sufficient overlap between
adjacent bursts and between sub-swaths to ensure the continuous coverage of the ground. The
images for all bursts in all sub-swaths are resampled to a common pixel spacing grid in range and
azimuth while preserving the phase information.
To add TOPSAR-Deburst operator, go to Add → Radar → Sentinel-1 TOPS → TOPSAR-Deburst.

In the TOPSAR-Deburst tab select Polarizations: VV.

Finally add the Write operator, go to Add → Input-Output → Write and connect it with the TOPSARDeburst operator. in the Write tab define the output directory as:
/shared/Training/HAZA03_LandSubsidence_MexicoCity_TutorialKit/Processing
Set the name of the output product as:
S1A_20160606_S1A_20160910_Split_Orb_Coregi_ESD_Ifg_Deb
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At this moment, save the graph as Graph_process_1.xml in /shared/Training/HAZA03_Land
Subsidence_MexicoCity_TutorialKit/Processing by clicking Save at the bottom of the window.
Then click Run. The new product will appear in the Product Explorer window. This might take
approximately 40 minutes depending on your machine.

Now open a new Graph Builder window to create a new graph for the next processing steps. In the
Read operator define as input name the previously produced interferogram:
S1A_20160606_S1A_20160910_Split_Orb_Coregi_ESD_Ifg_Deb

The next step is to remove the topographic induced phase from the debursted interferogram. To do
so, we have to add the TopoPhaseRemoval operator. Go to Add → Radar → Interferometric →
Products → TopoPhaseRemoval, keep the default parameters, and select the “Output topographic
phase band” option.
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As the original SAR image contains inherent speckle noise, multilook processing is applied at this
moment to reduce the speckle appearance and to improve the image interpretability. To add the
Multilook operator go to Add → Radar → Multilook.

In the Multilook tab set the following parameters:
Number of Range Looks: 8
Number of Azimuth Looks: 2

At this stage we will perform phase filtering of the interferogram in order to reduce phase noise e.g.,
for visualization or to aid the phase unwrapping which will be shown in the next step. The filtering
method we will implement in this operator is Goldstein method proposed by Goldstein & Werner in
1998 [4]. To add the GoldsteinPhaseFiltering operator go to Add → Radar → Interferometric →
Filtering → GoldsteinPhaseFiltering. Connect it to the Multilook operator.
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In the GoldsteinPhaseFiltering tab set the parameters as defined below:
Adaptive Filter Exponent in (0,1]: 1.0
FFT Size: 128

In this step we have to save the output, which is the multilooked and filtered differential
interferogram. Add the Write operator by going to Add → Input-Output → Write and connect it
with the GoldsteinPhaseFiltering operator.

In the Write tab define the output directory as:
/shared/Training/HAZA03_LandSubsidence_MexicoCity_TutorialKit/Processing
Set the name of the output product as:
S1A_20160606_S1A_20160910_Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt (See

NOTE 5)

NOTE 5: For each new operator in the GraphBuilder a corresponding suffix is added in the output
product name.

The final step in this processing part is to export the data for SNAPHU processing in order to apply
phase unwrapping. For a general reference on phase unwrapping see Ghiglia and Pritt [5],
Constantini [6]. To export data (bands) in the format compatible for SNAPHU processing, go to Add
→ Radar → Interferometric → Unwrapping → SnaphuExport and connect it with the
GoldsteinPhaseFiltering operator as well.
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In the SnaphuExport tab specify the full path to “Target folder” and save in
/shared/Training/HAZA03_LandSubsidence_MexicoCity_TutorialKit/Processing/SNAPHU. In this
case, you will have to create a folder with the File name “SNAPHU” in the processing folder. Also, set
the parameters as indicated below (See
NOTE 6):
Statistical-cost mode: DEFO
Initial method: MCF
Number of Tile Rows: 1
Number of Tile Columns: 1
Row Overlap: 0
Column Overlap: 0
In the Target Folder, the following path will be created: /shared/Training/HAZA03_LandSubsidence
_MexicoCity_TutorialKit/Processing/SNAPHU.

NOTE 6: Number of tiles is specified depending on the memory allocated to your machine.

At this moment, save the graph as Graph_process_2.xml in /shared/Training/HAZA03_Land
Subsidence_MexicoCity_TutorialKit/Processing by clicking Save at the bottom of the window.
Then click Run. This will take approximately 2 minutes depending on your VM.
Now, we can close the GraphBuilder window. In the Product Explorer window, the new
(multilooked) output product has been added. We can expand the Bands folder and select the
“Phase_ifg_VV_06Jun2016_10Sept2016” band. In the View window we can see the output
differential interferogram, where the phase is represented in the form of fringes (-pi, pi).
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5.7

Phase Unwrapping – Displacement Map

We are about to proceed with phase unwrapping via SNAPHU. Open a Linux terminal and navigate
to:
cd /shared/Training/HAZA03_Land_Subsidence_MexicoCity_TutorialKit/Processing/SNAPHU/
S1A_20160606_S1A_20160910_Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt

TIP: Write the first few letters of each folder name and click Tab to auto-complete. For example, “cd
/sh” + Tab → “cd /shared/” → “cd /shared/Tr” + Tab → “cd /shared/Training” …

Now, open configuration file “snaphu.conf” and copy the following command to call “snaphu”:
snaphu -f snaphu.conf Phase_ifg_VV_06Jun2016_10Sept2016.snaphu.img 2959
and paste it in the Terminal. Also, add the comment (#) before “LOGFILE”. Proceed by executing the
command. The results are stored in the above-mentioned folder.

Now, open a new Graph Builder window to create a new graph for the next processing steps. Now,
add one more Read operator. Right click and go to Add → Input-Output → Read.
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In the Read tab select the opened differential interferogram, saved in:
shared/Training/HAZA03_LandSubsidence_MexicoCity_TutorialKit/Processing:
S1A_20160606_S1A_20160910_Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt

In the Read(2) tab select the following: UnwPhase_ifg_VV_06Jun2016_10Sep2016.snaphu.hdr from
the /shared/Training/HAZA03_LandSubsidence_MexicoCity_TutorialKit/Processing/SNAPHU/S1A_
20160606_S1A_20160910_Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt/ folder.

The first step is to import the results from SNAPHU processing and to construct the interferometric
product that contains the unwrapped phase band, and the metadata of the source interferometric
product. Go to Add → Radar → Interferometric → Unwrapping → Snaphu Import and connect it
with the two Read operators.

In the SnaphuImport tab select the “Do NOT save Wrapped Interferogram in the target product”
option.

The second step is to convert the interferometric phase to displacement and to produce the
displacement product. Go to Add → Radar → Interferometric → Products → PhaseToDisplacement
and connect it with the SnaphuImport operator.
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In the PhaseToDisplacement tab there are no parameters to specify.
Finally, add the Write operator by going to Add → Input-Output → Write and connect it with the
PhaseToDisplacement operator.

In the Write tab define the output unwrapped product as below:
Name: S1A_20160606_S1A_20160910_ Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt_Unw_Disp
Directory: /shared/Training/HAZA03_LandSubsidence_MexicoCity_TutorialKit/Processing

Click Run.
In the Product Explorer window select the “displacement” band from the new opened product to
open the displacement product in the view window.
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5.8

Geocoding

Due to topographical variations of a scene and the tilt of the satellite sensor, distances can be
distorted in the SAR images. Terrain corrections are intended to compensate for these distortions, so
that the geometric representation of the image will be as close as possible to the real world. For
geocoding the Sentinel-1 products we will use the Range Doppler Terrain Correction operator that
implements the Range Doppler orthorectification method [7].
Go to Radar → Geometric → Terrain Correction → Range-Doppler Terrain Correction.
In the I/O Parameters tab, set the following:
Input: S1A_20160606_S1A_20160910_ Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt_Unw_Disp
Output:
S1A_20160606_S1A_20160910_Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt_Unw_Disp_TC
Directory: /shared/Training/HAZA03_LandSubsidence_MexicoCity_TutorialKit/Processing

In the Processing Parameters tab, set the following (See

NOTE 7):

Pixel Spacing (m): 100
Map Projection: WGS84(DD)
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NOTE 7: The pixel spacing in meters can be specified for the orthorectified image. Alternatively, default
pixel spacing computed from the source SAR image is used.

Now, click Run.
In the Product Explorer window select “displacement_VV” band to see the new geocoded product in
the View window.

By appropriate post-processing of the displacement product, like for example the masking of the
incoherent values, more accurate displacement measurements can be produced.
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6
6.1

Extra steps
Downloading the outputs from VM

Press Ctrl+Alt+Shift. A pop-up window will appear on the left side of the screen. Click on bar below
Devices, the folder structure of your VM will appear. Navigate to the folders you have saved the files
you want to download and double click any file you want to download. The downloading process to
your local computer will start automatically.

6.2

Export as KMZ (Google Earth)

If we want to view the products in Google Earth we have to export to KMZ format, readable by
Google Earth and then download results to our local PC for visualization, as the RUS VM does not
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support Google Earth installation. Readable KMZ format by Google Earth is WGS 84 Lat/Lon
coordinate system (EPSG 4326). If during the geocoding you have used a different coordinates
system, you need to reproject the final product in SNAP accordingly by going to Raster → Geometric
Operations → Reprojection.
Since our results are already in WGS 84, we proceed to the export of KMZ layer. In SNAP, go to File
→ Export → Other → View as Google Earth KMZ (only the active band open in the view window will
be saved).
Save to the Processing folder as: Mexico_disp.kmz.
Download the KMZ files to your laptop following the instructions in section 6.1.
Open Google Earth. Go to File → Open and open the downloaded layer. The new layer will appear as
overlay in the Places panel on the left (activate and deactivate layer and legend) with the name of
the original band (not the saved KMZ).

THANK YOU FOR FOLLOWING THE EXERCISE!
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Further reading and resources

SENTINEL-1 SAR User Guide Introduction – link
ESA Sentinel Online - link
Science Toolbox Exploitation Platform (STEP) – link
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