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TRAINING KIT – HAZA03
LAND SUBSIDENCE WITH SENTINEL-1 using SNAP
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Introduction

The Research and User Support for Sentinel core products (RUS) service provides a free and open
scalable platform in a powerful computing environment, hosting a suite of open source toolboxes
pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel
satellites constellation. In this tutorial we will employ RUS to identify and map land subsidence in
Mexico City using Sentinel-1 data.
Land subsidence in Mexico City caused
by groundwater overexploitation over
the last century has been more than 9
meters, resulting in damages to
buildings, streets, sidewalks, sewers,
storm water drains and other
infrastructure [1]. Previous studies of
SAR Interferometry using ERS data
showed a maximum subsidence rate
larger than 30 cm/year over parts of the
city [2].
Due to the fact that the city is partially
built on the area of a former lake (Lago
Texcoco), it rests on the heavily
saturated clay which is collapsing due to the over-extraction of groundwater. Current subsidence
rates using Sentinel-1 SAR data approximate 2.5 cm/month [3].
Mexico City’s buildings are seriously leaning due to land subsidence. Photo
credit: JOSH HANER/THE NEW YORK TIMES (http://www.sciencemag.org)
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Training

Approximate duration of this training session is two hours.
The Training Code for this tutorial is HAZA03. If you wish to practice the exercise described below
within the RUS Virtual Environment, register on the RUS portal (rus-copernicus.eu) and open a
User Service request from Your RUS service > Your dashboard.
2.1
•

Data used
Two Sentinel-1A images acquired on June 6, 2016 and September 10, 2016.
[downloadable @ https://scihub.copernicus.eu/]

S1A_IW_SLC__1SSV_20160606T122537_20160606T122601_011590_011B5B_E555.zip
S1A_IW_SLC__1SSV_20160910T122542_20160910T122606_012990_0148FA_76D7.zip

•

2.2

Auxiliary data stored locally
@ /shared/Training/HAZA03_Land Subsidence_Mexico_TutorialKit/AuxData
Software in RUS environment

Internet browser, SNAP + Sentinel-1 Toolbox, (Extra steps: Google Earth)
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3.1

Step by step
Data download – ESA SciHUB

In this step we will download two Sentinel-1 scenes from the Copernicus Open Access Hub using the
online interface (Applications -> Network -> Web Browser, or click the link below).
Go to https://scihub.copernicus.eu/

Go to Open HUB. If you already have an account proceed to login. If not, please register in the upper
right corner.

After you have filled in the registration form you will receive an activation link by e-mail. Once your
account is activated, log in.
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Select the “Pan” icon in the lower left corner of the map and navigate over Mexico City.

Switch to “Box” icon and draw a search rectangle approximately as indicated above (approximate
area – blue rectangle). Open the search menu ( ) and specify the following parameters. Press the
search button ( ) after that.
Sensing period: From 2016/06/06 to 2016/06/06
Check Mission: Sentinel-1A
Product Type: SLC
Sensor Mode: IW
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In our case the search returns 1 result depending on the exact search area defined. Download the
scene:
S1A_IW_SLC__1SSV_20160606T122537_20160606T122601_011590_011B5B_E555

Repeat the steps for the second image September 10, 2016, by changing accordingly the sensing
period range. Download the scene:
S1A_IW_SLC__1SSV_20160910T122542_20160910T122606_012990_0148FA_76D7

Data will be downloaded to /home/rus/Downloads as zip archives. Move the archives to:
/shared/Training/HAZA03_Land Subsidence_Mexico_TutorialKit/Original.

3.2

SNAP – open and explore data

Launch SNAP (icon on desktop
). When the SNAP window opens click Open product , navigate
to /shared/Training/HAZA03_Land Subsidence_Mexico _TutorialKit/Original and open the *.zip files.
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The opened products will appear in the Product Explorer pane on the left. Expand the first image to
the left and select Bands. Right click on the “Intensity_IW3_VV” and select Open Image Window to
create and visualize the image for the selected band. (See
NOTE 1).

The image appears in the upper left corner of the view window. Do the same for the second product.
To synchronize the views go to Navigation pane in the lower left (red arrow) and make sure the
cursor
and the views
are linked.
NOTE 1: The Interferometric
Wide (IW) swath mode
captures three sub-swaths
using Terrain Observation
with Progressive Scans SAR
(TOPSAR). Each sub-swath
image consists of a series of
bursts. The input product
contains 3 IW bands, and 8
bursts. Mexico City is located
on the IW3 sub-swath of the
Sentinel-1 images.

3.3

3
4
5

Pre-processing

Since the area of interest is included in 3 bursts of the Sentinel-1 image there is no need to process
the whole sub-swath with the 8 bursts (See
NOTE 2). The extraction of Sentinel-1 TOPS bursts will
be made per acquisition and per sub-swath. This process will reduce the processing time in the
following processing steps and is recommended when the analysis is focused only over a specific area
and not the complete scene. Click Radar -> Sentinel-1 TOPS -> S-1 TOPS Split.
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Now, let’s set the parameters. In the source product select the opened image:
S1A_IW_SLC__1SSV_20160606T122537_20160606T122601_011590_011B5B_E555.zip

Then, define the output directory in:
/shared/Training/HAZA03_Land Subsidence_Mexico _TutorialKit/Processing.
For the target product name leave the default output name. Please be aware that the system inserts
automatically the suffix of the split process in order to discriminate the split product from the original
data.

In the Processing Parameters tab select the following parameters. In bursts selection click on the
arrows and drag up to the specified number of bursts. Then click RUN.
Subswath: IW3
Polarisations: VV
Bursts: 3 to 5
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Repeat the split process for the second Sentinel-1 image using same processing parameters:
S1A_IW_SLC__1SSV_20160910T122542_20160910T122606_012990_0148FA_76D7

NOTE 2: The extraction of bursts in a sub-swath covering the area of interest may differ in Sentinel-1
images acquired on different dates.

3.4

Graph Builder

Although data processing could follow a manual step-by-step process, Graph Builder tool available in
SNAP allows the automatic processing of the images.

The Graph Builder tool allows the user to assemble graphs from a list of available operators and
connect operator nodes to their sources. Therefore, the processing chain we will follow, will be
represented by a graph and saved as an XML file. It is advisory to set the parameters in each operator
after the final graph is connected.
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In order to add Graph Builder tool, go to Tools -> GraphBuilder.
Initially, the graph has two operators: Read (to read the input) and Write (to write the output) (See
NOTE 3). With right-click on the top panel you can add an operator, while a corresponding tab is
created and added on the bottom panel.
Since pre-processing split process has preceded, in the Read tab select the name of the split product:
S1A_IW_SLC__1SSV_20160606T122537_20160606T122601_011590_011B5B_E555_split.dim.

NOTE 3: In case split process is already applied, input image in the Read tab will be the splitted product
of the Sentinel-1 image.

3.5

Co-registration

The first processing step is to apply the orbit files in Sentinel-1 products in order to provide accurate
satellite position and velocity information. To add the operator right-click on the top panel between
the existing operators and go to Add -> Radar -> Apply-Orbit-File.
A new operator rectangle appears in our graph and a new tab appears below. Now connect the new
Apply-Orbit-File operator with the Read operator by clicking to the right side of the Read operator
and dragging the red arrow towards the Apply-Orbit-File operator.

In the Apply-Orbit File tab select the parameters:
Orbit State Vectors: Sentinel Precise (Auto Download)
Check “Do not fail if new orbit file is not found”
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Now, we have to repeat the same steps for the second image. First we need to add a new Read
operator. Right-click and go to Add -> Input-Output -> Read. Select the split product:
S1A_IW_SLC__1SSV_20160910T122542_20160910T122606_012990_0148FA_76D7_split.dim

Then, go to Add -> Radar -> Apply-Orbit-File and select the same parameters.

Next step will be to co-register the two Sentinel-1 images. For this reason the second image (slave)
will be co-registered with respect to the first image (master). Sentinel-1 Back Geocoding operator coregisters two S-1 split products (master and slave) of the same sub-swath using the orbits of the two
products and a Digital Elevation Model (DEM). By right-clicking somewhere left of the Apply-OrbitFile operator, go to Add -> Radar -> Coregistration -> S-1 TOPS Coregistration -> Back-Geocoding.
Connect the Back-Geocoding operator with the Apply-Orbit-File operators.

In the Back-Geocoding tab use default parameters, but also check “Output Deramp and Demod
Phase” (See
NOTE 4).
NOTE 4: Deramp and Demod Phase is required when ESD operator follows Back-Geocoding.
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In this step, Enhanced Spectral Diversity (ESD) operator follows Backgeocoding. The ESD approach
exploits the data at the overlapped area of the adjacent bursts, and then performs range and
azimuth correction for every burst. In the same manner, go to Add -> Radar -> Coregistration -> S-1
TOPS Coregistration -> Enhanced-Spectral-Diversity and then connect ESD and Back-Geocoding
operators.

In the Enhanced-Spectral-Diversity tab use the default parameters.
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3.6

Interferometric Processing

At this stage, we will produce an Interferogram between the interferometric pair (master and slave),
while a coherence image estimation from the stack of the coregistered complex images is included.
To add the Interferogram operator go to Add -> Radar -> Interferometric -> Products ->
Interferogram add then connect the Interferogram operator to Enhanced-Spectral-Diversity
operator.

In the Interferogram tab set the following parameters:
Coherence Range Window Size: 20
Coherence Azimuth Window Size: 5

We continue the processing steps with Sentinel-1 TOPSAR Deburst. We have seen that each subswath image consists of a series of bursts, where each burst has been processed as a separate SLC
image. The individually focused complex burst images are included, in azimuth-time order, into a
single sub-swath image with black-fill demarcation in between. There is sufficient overlap between
adjacent bursts and between sub-swaths to ensure the continuous coverage of the ground. The
images for all bursts in all sub-swaths are resampled to a common pixel spacing grid in range and
azimuth while preserving the phase information. To add TOPSAR-Deburst operator, go to Add ->
Radar -> Sentinel-1 TOPS -> TOPSAR-Deburst.
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In the TOPSAR-Deburst tab select Polarizations: VV.

Connect the Write operator with the TOPSAR-Deburst operator and in the Write tab define the
output directory as:
/shared/Training/HAZA03_Land Subsidence_Mexico _TutorialKit/Processing
Set the name of the output product as:
S1A_20160606_S1A_20160910_Split_Orb_Coregi_ESD_Ifg_Deb

13

At this moment, save the graph as Graph_process_1.xml in /shared/Training/HAZA03_Land
Subsidence_Mexico _TutorialKit/Processing by clicking Save at the bottom of the window.
Then click Run. This might take approximately 23 minutes depending on your machine. The new
product will appear in the Product Explorer pane.

Now open a new Graph Builder window to create a new graph for the next processing steps. In the
Read operator define as input name the previously produced interferogram:
S1A_20160606_S1A_20160910_Split_Orb_Coregi_ESD_Ifg_Deb

The next step is to remove the topographic induced phase from the debursted interferogram. To do
so, we have to add the TopoPhase Removal operator. Go to Add -> Radar -> Interferometric ->
Products -> TopoPhase Removal and select the option “Output topographic phase band”.

As the original SAR image contains inherent speckle noise, multilook processing is applied at this
moment to reduce the speckle appearance and to improve the image interpretability. To add the
Multilook operator go to Add -> Radar -> Multilook.
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In the Multilook tab set the following parameters:
Number of Range Looks: 8
Number of Azimuth Looks: 2

At this stage we will perform phase filtering of the interferogram in order to reduce phase noise e.g.,
for visualization or to aid the phase unwrapping which will be shown in the next step. The filtering
method we will implement in this operator is Goldstein method proposed by Goldstein & Werner in
1998 [4]. To add the Goldstein Phase Filtering operator follow the path Add -> Radar ->
Interferometric -> Filtering -> GoldsteinPhaseFiltering.

In the GoldsteinPhaseFiltering tab set the parameters as defined below:
Adaptive Filter Exponent in (0,1]: 1.0
FFT Size: 128
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In this step we have to save the output, which is the multilooked and filtered differential
interferogram. Connect the Write operator with the GoldsteinPhaseFiltering operator.

In the Write tab define the output directory as:
/shared/Training/HAZA03_Land Subsidence_Mexico _TutorialKit/Processing
Set the name of the output product as:
S1A_20160606_S1A_20160910_Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt (See

NOTE 5)

NOTE 5: For each new operator in the GraphBuilder a corresponding suffix is added in the output
product name.
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The final step in this processing part is to export the data for SNAPHU processing in order to apply
phase unwrapping. For a general reference on phase unwrapping see Ghiglia and Pritt [5],
Constantini [6]. To export data (bands) in the format compatible for SNAPHU processing go to Add ->
Radar -> Interferometric -> Unwrapping -> SnaphuExport.

In the SnaphuExport tab specify the full path to “Target folder” and save in
/shared/Training/HAZA03_Land Subsidence_Mexico _TutorialKit/Processing/SNAPHU. Also, set the
parameters as indicated below (See
NOTE 6):
Statistical-cost mode: DEFO
Initial method: MCF
Number of Tile Rows: 1
Number of Tile Columns: 1

At this moment, save the graph as Graph_process_2.xml in /shared/Training/HAZA03_Land
Subsidence_Mexico _TutorialKit/Processing by clicking Save at the bottom of the window.
Then click Run. This might take less than a minute.
Now, we can close the GraphBuilder window. In the Product Explorer the new output product has
been added. We can go to Bands and select “Phase_ifg_VV_06Jun2016_10Sept2016”. In the view
window we can see the output differential interferogram, where the phase is represented in the
form of fringes (-pi, pi).
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NOTE 6: Number of tiles is specified depending on the memory allocated to your machine.

3.7

Phase Unwrapping

We are at the point to proceed with phase unwrapping via SNAPHU. Open a Linux terminal and
navigate to /shared/Training/HAZA03_Land Subsidence_Mexico_TutorialKit/Processing/SNAPHU/
S1A_20160606_S1A_20160910_ Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt.

Now, open configuration file “snaphu.conf” and copy “command to call snaphu”:
snaphu -f snaphu.conf Phase_ifg_VV_06Jun2016_10Sept2016.snaphu.img 2959

and paste it in the Terminal. Also, in the “Output Files” use the comment (#) before “LOGFILE”.
Proceed by executing the command. The results are stored in the above-mentioned folder.
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The next step is to import the results from SNAPHU processing and to construct the interferometric
product that contains the unwrapped phase band, and the metadata of the source interferometric
product. Then, go to Radar -> Interferometric -> Unwrapping -> Snaphu Import.
In the Read-Phase tab select the opened differential interferogram,
/shared/Training/HAZA03_Land Subsidence_Mexico _TutorialKit/Processing:

saved

in

S1A_20160606_S1A_20160910_ Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt

In the Read-Unwrapped-Phase tab select the following:
/shared/Training/HAZA03_LandSubsidence_Mexico_TutorialKit/Processing/SNAPHU/S1A_20160606_S
1A_20160910_Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt/UnwPhase_ifg_VV_06Jun2016_10Sep2016.sna
phu.hdr

In the SnaphuImport tab select option “Do NOT save Wrapped Interferogram in the target product”.
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In the Write tab define the output unwrapped product as below:
Name: S1A_20160606_S1A_20160910_ Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt_Unw
Directory: /shared/Training/HAZA03_Land Subsidence_Mexico_TutorialKit/Processing

3.8

Displacement Map

At this moment, we will convert the interferometric phase to displacement map. Go to Radar ->
Interferometric -> Products -> Phase to Displacement. Now, let’s set the parameters.
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In the Input/Output Parameters tab select the following:
Input: S1A_20160606_S1A_20160910_Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt_Unw
Output: S1A_20160606_S1A_20160910_Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt_Unw_Dsp
Leave the default processing parameters and then click Run.
In the Product Explorer pane select “displacement” band from the new opened product to open the
displacement product in the view window.

3.9

Geocoding

Due to topographical variations of a scene and the tilt of the satellite sensor, distances can be
distorted in the SAR images. Terrain corrections are intended to compensate for these distortions, so
21

that the geometric representation of the image will be as close as possible to the real world. For
geocoding the Sentinel-1 products we will use the Range Doppler Terrain Correction operator that
implements the Range Doppler orthorectification method [7].
To add Range Doppler Terrain Correction operator go to Radar -> Geometric -> Terrain Correction ->
Range-Doppler Terrain Correction.
In the Input/Output tab set the following parameters:
Input: S1A_20160606_S1A_20160910_ Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt_Unw_Dsp
Output: S1A_20160606_S1A_20160910_Split_Orb_Coregi_ESD_Ifg_Deb_DInSAR_ML_Flt_Unw_Dsp_TC100
Directory: /shared/Training/HAZA03_Land Subsidence_Mexico_TutorialKit/Processing

NOTE 7: The pixel spacing in meters can be specified for the orthorectified image. Alternatively, default
pixel spacing computed from the source SAR image is used.
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In the Processing Parameters tab set the following parameters (See

NOTE 7):

Pixel Spacing (m): 100
Map Projection: WGS84(DD)
Now, click Run.
In the Product Explorer pane select “displacement_VV” band to see the new geocoded product in the
view window.
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By appropriate post-processing of the displacement product, like for example the masking of the
incoherent values, more accurate displacement measurements can be produced.
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4
4.1

Extra steps
Downloading the outputs from VM

Press Ctrl+Alt+Shift. A pop-up window will appear on the left side of the screen. Click on bar below
Devices, the folder structure of your VM will appear. Navigate to your Processing folder and double
click any file you want to download.

4.2

Export as KMZ (Google Earth)

If we want to view the products in Google Earth we have to export to KMZ format readable by
Google Earth and then download results to our local PC for visualization, as the RUS VM does not
support Google Earth installation. Readable KMZ format by Google Earth should be in WGS 84
Lat/Lon coordinate system (EPSG 4326). Otherwise you have to re-project in SNAP according the path
Raster -> Geometric Operations -> Reproject.
Since our results are already in WGS’84 we proceed to export the KMZ layer. In SNAP go to File ->
Export -> Other -> View as Google Earth KMZ (only the active band open in the view window will be
saved).
Save to the Processing folder as: Mexico_disp.kmz.
Download the KMZ files to your laptop following the instructions in section 4.1.
Open Google Earth. Go to File -> Open and open the downloaded layer. The new layer will appear as
overlay in the Places panel on the left (activate and deactivate layer and legend) with the name of
the original band (not the saved KMZ).
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5

Further reading and resources

SENTINEL-1 SAR User Guide Introduction – link
ESA Sentinel Online - link
Science Toolbox Exploitation Platform (STEP) – link
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