_p

TRAINING KIT – LAND07
DFSDFGAGRIAGRAGRI

DEFORESTATION MONITORING WITH SENTINEL-1
Case Study: Paraguay, 2018

Research and User Support for Sentinel Core Products

The RUS Service is funded by the European Commission, managed by the European Space
Agency and operated by CSSI and its partners.
Authors would be glad to receive your feedback or suggestions and to know how this
material was used. Please, contact us on training@rus-copernicus.eu
Cover images produced by RUS Copernicus

The following training material has been prepared by Serco Italia S.p.A. within the RUS
Copernicus project.
Date of publication: December 2018
Version: 1.2

Suggested citation:
Serco Italia SPA (2018). Deforestation monitoring with Sentinel-1. (version 1.2). Retrieved
from RUS Lectures at https://rus-copernicus.eu/portal/the-rus-library/learn-by-yourself/

This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0
International License.

DISCLAIMER
While every effort has been made to ensure the accuracy of the information contained in this publication, RUS
Copernicus does not warrant its accuracy or will, regardless of its or their negligence, assume liability for any
foreseeable or unforeseeable use made of this publication. Consequently, such use is at the recipient’s own risk on
the basis that any use by the recipient constitutes agreement to the terms of this disclaimer. The information
contained in this publication does not purport to constitute professional advice.

2

Table of Contents
1

Introduction to RUS ......................................................................................................................... 4

2

Deforestation – background............................................................................................................ 4

3

Training ............................................................................................................................................ 4
3.1

Data used ................................................................................................................................. 4

3.2

Software in RUS environment ................................................................................................. 4

4

Register to RUS Copernicus ............................................................................................................. 5

5

Request a RUS Copernicus Virtual Machine .................................................................................... 6

6

Step by step ................................................................................................................................... 10
6.1

Data download – ESA SciHUB ................................................................................................ 10

6.2

Download data ...................................................................................................................... 10

6.3

Sentinel-1 SNAP Pre-processing ............................................................................................ 13

6.3.1

Apply Orbit File .............................................................................................................. 14

6.3.2

Thermal Noise Removal................................................................................................. 14

6.3.3

Calibration ..................................................................................................................... 15

6.3.4

Speckle Filtering ............................................................................................................ 15

6.3.5

Terrain Correction ......................................................................................................... 15

6.3.6

Subset ............................................................................................................................ 16

6.3.7

Convert Data Type ......................................................................................................... 17

6.3.8

GLCM ............................................................................................................................. 17

6.3.9

Band Merge ................................................................................................................... 18

6.3.10

Write .............................................................................................................................. 18

6.4

AOI Monitoring ...................................................................................................................... 19

6.5

Random Forest Classification ................................................................................................ 21

7

Post-processing ............................................................................................................................. 24

8

Multi-temporal RGB ...................................................................................................................... 26

9

QGIS Visualization ......................................................................................................................... 27

10

Further reading and resources .................................................................................................. 29

3

1

Introduction to RUS

The Research and User Support for Sentinel core products (RUS) service provides a free and open
scalable platform in a powerful computing environment, hosting a suite of open source toolboxes
pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel
satellites constellation.
In this tutorial, we will employ RUS to monitor on-going deforestation in the Chaco region, located in
the north of Paraguay, using Sentinel-1 GRD data as input data to run a supervised classification
(Random Forest).
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Deforestation – background
Forests cover almost a third of world's land surface,
representing one of the most important
ecosystems in our planet and a fundamental
element to fight climate change. They provide
fundamental ecosystem services such as absorbing,
storing and converting carbon dioxide (C02) into
oxygen or reducing the effect of erosion caused by
wind and rain amongst other. Moreover, forests
create natural habitat to a large variegate of flora
and fauna species hence preserving global

biodiversity.
Rapid shrinking of forest creates a major threat and increases the effects of climate change. Every
year, large forested areas are cleared out all over the world due to different driving forces and
precise monitoring of these activities is required to reduce their negative impact.
The Copernicus program, which includes a new family of earth observation satellites known as the
Sentinels, provides a unique opportunity to quickly map the ever-changing forests and provide
regular updates on their condition at a range of spatial and temporal resolutions.
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Training

Approximate duration of this training session is one hour.
The Training Code for this tutorial is LAND07. If you wish to practice the exercise described below
within the RUS Virtual Environment, register on the RUS portal and open a User Service request
from Your RUS service -> Your dashboard.
3.1
•

3.2

Data used
5 Sentinel-1B images acquired from June 2017 until November 2018 [downloadable at
https://scihub.copernicus.eu/ using the .meta4 file provided in the Original folder Preprocessed data stored locally
@/shared/Training/LAND07_DeforestationMonitoring_Paraguay/AuxData/
Software in RUS environment
Internet browser, SNAP + S1 Toolbox
4
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Register to RUS Copernicus

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as
a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on
Login/Register in the upper right corner.

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus
Users’ Single Sign On Registration. Click Register.

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the email to activate your account.
You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter
your chosen credentials.
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Upon your first login you will need to enter some details. You must fill all the fields.
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Request a RUS Copernicus Virtual Machine

Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise
or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service →
Your Dashboard.
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that
the appropriate cloud environment can be assigned according to your needs.

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the
appropriate field.

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your
request once you are finished.
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email
with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your
Dashboard and click on Access my Virtual Machine.
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access
your RUS Copernicus Virtual Machine.

This is the remote desktop of your Virtual Machine.
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6
6.1

Step by step
Data download – ESA SciHUB

Before starting the exercise, make sure you are registered in the Copernicus Open Access Hub so that
you can access the free data provided by the Sentinel satellites.
Go to https://scihub.copernicus.eu/

Go to Open Hub. If you do not have an account, sign up in the upper right corner, fill in the details
and click register.

You will receive a confirmation email on the e-mail address you have specified: open the email and
click on the link to finalize the registration.
Once your account is activated – or if you already have an account – log in.
6.2

Download data

In this exercise, we will analyse 5 Sentinel-1B images acquired during 2017 and 2018. The following
table shows the date and reference of the images that will be used:
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SATELLITE

Sentinel-1B

DATE

IMAGE ID

2017-06-11

S1B_IW_GRDH_1SDV_20170611T223258_20170611T223327_006008_00A8BA_DC5E

2017-12-08

S1B_IW_GRDH_1SDV_20171208T223303_20171208T223332_008633_00F558_1DC7

2018-01-13

S1B_IW_GRDH_1SDV_20180113T223301_20180113T223330_009158_01064E_8B75

2018-06-06

S1B_IW_GRDH_1SDV_20180606T223304_20180606T223333_011258_014AA1_3FAC

2018-11-21

S1B_IW_GRDH_1SDV_20181121T223310_20181121T223339_013708_019648_0322

To improve the data acquisition process, we will use a download manager (See
NOTE 1) that will
take care of downloading all products that will be used in this exercise. The metadata of the Sentinel
products are contained in a products.meta4 file created using the ‘Cart’ option of the Copernicus
Open Access Hub.
NOTE 1: A download manager is a computer program dedicated to the task of downloading possibly
unrelated stand-alone files from (and sometimes to) the Internet for storage. For this exercise, we will
use aria2. Aria2 is a lightweight multi-protocol & multi-source command-line download utility. More
info at: https://aria2.github.io/

The products.meta4 file containing the links to the Sentinel-1 products to be downloaded can be
created following the methodology explained in
NOTE 2. Follow the instructions and create your
cart file, download it and save it in the following path:
Path: /shared/Training/LAND07_DeforestationMonitoring_Paraguay/Original/
Before using the downloading manager and the .meta4 file, let’s test if aria2 is properly installed in
the Virtual Machine. To do this, open the Command Line (in the bottom of your desktop window)
type the following command and press Enter.
aria2c

If aria2 is properly installed, the response should be as follows. If the response is ‘-bash aria2c:
command not found’ it means aria2 is not installed (See
NOTE 3).
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NOTE 2: The Copernicus Open Access Hub allows you to add products to a ‘Cart’. For that, perform a
query; select the desired products from the result list and click on the ‘Add Product to Cart’ icon - . To
find the appropriate images, copy-paste the image ID specified in the table (pg. 11) in the search box of
the Copernicus Open Access Hub.

To view the products present in the cart just click anytime on the User Profile icon on top right corner of
the screen and then on "Cart". To download the cart click on "Download Cart" on the bottom right of
the page. A download window will pop up, asking the user confirmation to save a .meta4 file named
‘products.meta4’. This file contains all the metalinks of the products.
NOTE 3: If (and only if) the response is ‘-bash aria2c: command not found’, you need to install aria2. In
the command line, type:
sudo apt-get install aria2
When requested, type:
Y
Once finished, test the installation as explanied before.

Once aria2 is ready to use, we can start the download process. For that, we need to navigate to the
folder where the products.meta4 is stored. Type the following command in the terminal and run it.
cd /shared/Training/LAND07_DeforestationMonitoring_Paraguay/Original/

Next, type the following command (in a single line) to run the download tool. Replace username and
password (leave the quotation marks) with your login credentials for Copernicus Open Access Hub
(COAH). Do not clear your cart in the COAH until the download process is finished.
aria2c --http-user='username' --http-passwd='password' --check-certificate=
false --max-concurrent-downloads=2 -M products.meta4
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The Sentinel products will be stored in the same path where the products.meta4 is located. Move the
image from 2018-11-21 to the following path (it will be used later to test the monitoring capabilities
of SNAP).
Path: /shared/Training/LAND07_DeforestationMonitoring_Paraguay/New_S1_images/
6.3

Sentinel-1 SNAP Pre-processing

Open SNAP (Applications -> Processing or click on the desktop icon). Click on File -> Open Product,
navigate to the following path and open all the 4 Sentinel-1 products
Path: /shared/Training/LAND07_DeforestationMonitoring_Paraguay/Original/
The opened products will appear in the Product Explorer. Click + to expand the contents of the file
from June 2017, then expand Bands and double click Intensity_VV to visualize the band.

Before being able to use the Sentinel-1 products for our application, we need to apply identical preprocessing steps to all our scenes. However, processing the data step by step and product by product
would be time consuming and inconvenient. Luckily, we can use the Graph Builder tool available in
SNAP to create a chain containing all the pre-processing steps we need to apply. This creates a first
level of automatization when dealing with large datasets. In addition, using graphs saves disk space
as only the final product is physically created and saved.
To start the process, open a new graph file by going to Tools -> GraphBuilder
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Now, the graph only has two operators: Read (to read the input) and Write (to write the output).
Right-clicking on the top panel, you can add an operator while a corresponding tab is created and
added on the bottom panel. To avoid confusion, delete the Write operator (right click on it-> Delete)
6.3.1 Apply Orbit File
First, we will update the orbit metadata of the Sentinel-1 products (See
NOTE 4). To add the
operator, right-click the white space between existing operators and go to Add -> Radar -> ApplyOrbit-File. Connect the new Apply-Orbit-File operator with the Read operator.
NOTE 4: The orbit state vectors provided in the metadata of a SAR product are generally not accurate
and can be refined with the precise orbit files which are available days-to-weeks after the generation of
the product. The orbit file provides accurate satellite position and velocity information. Based on this
information, the orbit state vectors in the abstract metadata of the product are updated. (SNAP Help)

In the corresponding tab, select the option Do not fail if new orbit is not found. In case precise orbits
are not found, restituted orbit files will be used.

6.3.2 Thermal Noise Removal
The next step will remove the thermal noise (See
NOTE 5). Add the operator by right-cliking on
the white area and go to Add -> Radar -> Radiometric -> ThermalNoiseRemoval. Connect the
ThermalNoiseRemoval operator with the Apply-Orbit-File operator. In the corresponding tab, leave
the default parameters.
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NOTE 5: Thermal noise in SAR imagery is the background energy that is generated by the receiver itself.
(SNAP Help) It skews the radar reflectivity to towards higher values and hampers the precision of radar
reflectivity estimates. Level-1 products provide a noise LUT for each measurement dataset, provided in
linear power, which can be used to remove the noise from the product.

6.3.3 Calibration
Now, we can add the Calibration operator. The objective of SAR calibration is to provide imagery in
which the pixel values can be directly related to the RADAR backscatter. Though uncalibrated SAR
imagery is sufficient for qualitative use, calibrated SAR images are essential to quantitative use of
SAR data (See
NOTE 6). To add the operator go to Add -> Radar -> Radiometric -> Calibration.
Connect the ThermalNoiseRemoval operator to the Calibration operator. In the corresponding tab,
leave the default parameters.
NOTE 6: Typical SAR data processing, which produces level-1 images, does not include radiometric
corrections and significant radiometric bias remains. The radiometric correction is necessary for the
pixel values to truly represent the radar backscatter of the reflecting surface and therefore for
comparison of SAR images acquired with different sensors, or acquired from the same sensor but at
different times, in different modes, or processed by different processors. (SNAP Help)

6.3.4 Speckle Filtering
SAR images have inherent salt and pepper like texturing called speckles which degrade the quality of
effect and smooth the image we apply speckle filter (See
NOTE 7). To add the operator, go to
Radar -> Speckle Filtering -> Speckle-Filter then connect the Calibration operator to it. In the
corresponding tab, leave the default parameters.
NOTE 7: Speckle is caused by random constructive and destructive interference of the de-phased but
coherent return waves scattered by the elementary scatters within each resolution cell. Speckle noise
reduction can be applied either by spatial filtering or multilook processing. (SNAP Help)

6.3.5 Terrain Correction
Our data are still in radar geometry, moreover due to topographical variations of a scene and the tilt
of the satellite sensor, the distances can be distorted in the SAR images. Therefore, we will apply
terrain correction to compensate for the distortions and reproject the scene to geographic projection
(See
NOTE 8). To add the operator, go to Radar -> Geometric -> Terrain Correction -> TerrainCorrection then connect the Speckle-Filter operator to it.
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NOTE 8: The geometry of topographical distortions in SAR
imagery is shown on the right. Here we can see that point B
with elevation h above the ellipsoid is imaged at position B’
in SAR image, though its real position is B". The offset Δr
between B' and B" exhibits the effect of topographic
distortions. (SNAP Help)

In the corresponding tab, change the map projection to UTM / WGS 84 (Automatic).

6.3.6 Subset
Since we want to focus the analysis on our study area, we add the Subset operator to reduce the
extent of the final product. To add the operator go to Add -> Raster -> Geometric -> Subset. Connect
it to the Terrain-Correction operator. Select the option Geographic Coordinates and paste the
following coordinates in Well-Known-Text format. Click Update to load the coordinates and Zoom in
to the area.

POLYGON ((-60.6203727722168 -20.61688995361328, -60.19137191772461 -20.6168
8995361328, -60.19137191772461 -21.03205108642578, -60.6203727722168 -21.03
205108642578, -60.6203727722168 -20.61688995361328, -60.6203727722168 -20.6
1688995361328))
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Zoom in

6.3.7 Convert Data Type
Due to software requirements, we need to convert our products to bytes inputs since the GLCM
operator that we will use in the next step works with this data type. This step will allow us to have
both bands (Sigma0_VV and Sigma0_VH) in a common scale. To add the operator, go to Raster ->
Data Conversion -> Convert-Datatype. Connect the Subset operator to the Convert-Datatype
operator. In the corresponding tab, make sure to select int8 as Target Data Type

6.3.8 GLCM
To increase the amount of information, we will derive the Grey Level Co-occurrence Matrix (GLCM)
(See
NOTE 9). To add the operator, go to Raster -> Image Analysis -> Texture Analysis -> GLCM.
Connect the GLCM operator to the Subset operator. In the corresponding tab, make sure to select
11x11 as Window Size and the following features: Contrast, GLCM Mean, GLCM Variance.
NOTE 9: Spatial information in the form of texture features can be useful for image classification.
Texture measures can produce new images by making use of spatial information inherent in the image.
It involves the information from neighboring pixels which is important to characterize the identified
objects or regions of interest in an image.
The Gray Level Co-occurrence Matrix (GLCM) proposed by Haralik is one of the most widely used
methods to compute second order texture measures. Each feature models different properties of the
statistical relation of pixels co-occurrence estimated within a given moving window and along
predefined directions and inter-pixel distances. The GLCM is a measure of the probability of occurrence
of two grey levels separated by a given distance in a given direction (Source: SNAP Help)
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6.3.9 Band Merge
In the last step, we will combine the GLCM features derived in the previous step with the Sigma0
bands of the Sentinel-1 product. Merging all the bands in the same product will allow us to use them
as input in our classification. To add the operator, go to Raster -> Band Merge. Connect the GLCM
and Convert-DataType operators to Band Merge. In the corresponding tab, leave the default
parameters.

6.3.10 Write
Finally, we need to properly save the output. For that, we first need to add the Write operator to our
graph. Right click and navigate to Add -> Input-Output -> Write. Connect the Write operator to the
BandMerge operator. In the Write tab, leave the default output name and make sure you set the
following path as output directory.
Path: /shared/Training/LAND07_DeforestationMonitoring_Paraguay/Processing/
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Save the graph (Save icon at the bottom of the window) as S1_Processing.xml in the following path
and close the Graph Builder window. DO NOT RUN THE GRAPH YET.

Path: /shared/Training/LAND07_DeforestationMonitoring_Paraguay/AuxData/
6.4

AOI Monitoring

Deforestation is an evolving process that changes at different time rates and requires continuous
monitoring activities. For this reason, in this exercise we will use the Area Of Interest Monitoring (AOI
Monitoring) functionality of SNAP, which allows to specify, save, and load AOIs to be automatically
batch processed using a chain of processing steps defined with the Graph Builder.
Although regular batch processing could be used to pre-process our Sentinel-1 products, this
functionally adds a second level of automatization. By using this tool, each time a new image is
downloaded and stored in a pre-defined folder of the RUS Virtual Machine, SNAP will automatically
detect the product, process it and save the output in a pre-defined output directory ready to be used
for post-processing analysis. To start using AOI Monitoring, go to Tools -> AOI Monitoring.
First, we will create a new AOI. For that, click on the Create New AOI icon
. In the folder manager,
navigate to the following path and name the AOI as Chaco_Deforestation.xml.
Path: /shared/Training/LAND07_DeforestationMonitoring_Paraguay/AuxData/
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In the AOI Menu window that appears, set the input folder parameter to the directory where the
original Sentinel-1 products are stored (see Path1). Set the output directory to the folder where the
results will be saved (See Path2). Specify the path to the graph that will be used to analyse the input
images (See Path3).
Path1 → /shared/Training/LAND07_DeforestationMonitoring_Paraguay/Original/
Path2 → /shared/Training/LAND07_DeforestationMonitoring_Paraguay/Processing/
Path3 → /shared/Training/LAND07_DeforestationMonitoring_Paraguay/AuxData/S1_Processing.xml
In the bottom part of the AOI Menu, a world map is shown to geographically locate our AOI by
drawing a polygon. Specify the AOI by drawing a rectangle over South America in the world map.
(See
NOTE 10). Click Ok.
NOTE 10: It is not necessary to locate our study area precisely in the world map. This step will only
identify the Sentinel products that overlap with the area and are candidate to be analyzed by the predefined processing chain. If no rectangle is drawn, then the entire globe is the AOI.

Once the AOI is defined, it will appear in the list. To start processing our Sentinel-1 products, select
the AOI and click on the Process selected AOI button

.
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The AOI Monitoring tool will start the search for products in the AOI in the input folder. The "Batch
Processing" window will open in few seconds populated with the search results. Products that have
already been processed will be excluded from the search results. If there are no products inside the
AOI or they have all been processed, a warning message will pop up.
Since the products that will be detected will be loaded randomly, use the Move up and Move down
arrows to put them in the desired order, from the oldest to the most recent and click Run to start
batch processing. Wait until the process is completed, close the Batch Processing window and close
(right click on the product -> Close Product) the 4 original Sentinel-1 products from the Product
Explorer.

To start monitoring our AOI, click the Begin Monitoring all AOI folders button
(it will turn red
and become the Stop monitoring AOIs button). When a new product in any of the AOI folders is
found to be covered in whole or partially by the AOI, that AOI will be queued for batch processing. To
test this capability, move the Sentinel-1 product located in Path1 (see below) to Path2 (see below).
Path1 → /shared/Training/LAND07_DeforestationMonitoring_Paraguay/New_S1_images/
Path1 → /shared/Training/LAND07_DeforestationMonitoring_Paraguay/Original/
Since AOI Monitoring is active, SNAP will automatically detect this product and start to process it
with the pre-defined graph (a new batch processing window will appear and start running). Wait until
the process is finished and then click the red Stop monitoring AOIs button to stop the monitoring (it
will turn back to green).
6.5

Random Forest Classification

In this exercise, we will use the Random Forest classification algorithm (See
NOTE 11) to
distinguish forest and non-forest areas in each Sentinel-1 product individually. Since we will run a
supervised classification, we need to import our training data which have been created in advance.
To import them, select the first Sentinel-1 pre-processed product in the Product Explorer window
(2017-06-11), go to Vector -> Import -> ESRI Shapefile, navigate to the following path, select the
Forest_Polygon.shp and Deforestation_Polygon.shp shapefiles and click Open. In the pop-up window,
select No.
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Path → /shared/Training/LAND07_DeforestationMonitoring_Paraguay/AuxData/

Save the product (Right click on the product -> Save product). The Vector Data folder of the product
contains now the shapefiles that have been imported and should look like this. Repeat the same
procedure for the 4 remaining products and remember to save them afterwards.

To start the classification procedure, click on Raster -> Classification -> Supervised Classification ->
Random Forest Classifier.
NOTE 11: The Random Forest algorithm is a machine learning
technique that can be used for classification or regression. In
opposition to parametric classifiers (e.g. Maximum Likelihood), a
machine learning approach does not start with a data model but
instead learns the relationship between the training and the
response dataset. The Random Forest classifier is an aggregated
model, which means it uses the output from different models
(trees) to calculate the response variable.
Decision trees are predictive models that recursively split a dataset into regions by using a set of binary
rules to calculate a target value for classification or regression purposes. Given a training set with n
number of samples and m number of variables, a random subset of samples n is selected with
replacement (bagging approach) and used to construct a tree. At each node of the tree, a random
selection of variables m is used and, out of these variables, only the one providing the best split is used to
create two sub-nodes.
By combining trees, the forest is created. Each pixel of a satellite image is classified by all the trees of the
forest, producing as many classifications as number of trees. Each tree votes for a class membership and
then, the class with the maximum number of votes is selected as the final class.
More information about Random Forest can be found in Breiman, 2001.

In the ProductSet-Reader tab, click on the
pre-processed image from 20170611.

symbol. Navigate to the following path and select the
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Path: /shared/Training/LAND07_DeforestationMonitoring_Paraguay/Processing/

Move to the Random-Forest-Classifier tab and set the following parameters:
-

Check the option Train and apply classifier
Uncheck the Evaluate classifier option
Set the number of trees to 500
Select all the shapefiles as training vectors
Select all the bands as feature bands

Click now on the Write tab, set the Output folder to the following path and leave the default name.
The, click Run.
Path: /shared/Training/LAND07_DeforestationMonitoring_Paraguay/Processing/

Once the product is created, expand the Bands folder, right click on the band LabelledClasses,
uncheck the option No-Data Value Used and delete the Valid pixel expression. Then, click Close and
save the product (Right click on the product -> Save Product).
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To visualize the result, double click on LabelledClasses band. You can change the colours by clicking
on the Colour Manipulation tab located in the lower left corner or by clicking on View -> Tool
Windows -> Colour manipulation. Repeat the classification procedure with the remaining images
(20171208, 20180113, 20180606, 20181121).
Once finished, close the 5 pre-processed Sentinel-1 images (indexes [5] – [9]) and leave only the
classified products (indexes [10] – [14]).
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Post-processing

Since we are using a SAR sensor as input for our classification, the inherent speckle noise of the
original data is still present in our results. In this occasion, we will use a morphological filter known as
closing (Dilation + Erosion) to clean our dataset. Expand the first classified product (20170611), open
the Bands folder and select the LabelledClasses band. Then, go to Raster -> Filtered Band. In the
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System tab go down to the Morphological filters. Select Closing 3x3, keep the Band name as default
and click Ok.

Expand the first classified product and go to the Bands folder. Open the LabelledClasses and
LabelledClasses_close3 and go to Windows -> Tile Horizontally to visualize them at the same time.
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Select the first product (20170611) and click on File -> Export -> GeoTIFF. Navigate to the following
path and set the name to RF_ + dates (e.g. RF_20170611). In the Export Product window, click on
Subset -> Band Subset. Select only the band LabelledClasses_close3. Then, click Ok and Export
Product.
Path: /shared/Training/LAND07_DeforestationMonitoring_Paraguay/Processing/

Repeat the complete procedure for the remaining products (20171208, 20180113, 20180606,
20181121) and named them RF_20171208, RF_20180113, RF_20180606 and RF_20181121.

8

Multi-temporal RGB

A different way of analysing the evolution of deforestation is to create multi-temporal RGB
compositions. For this, a raster stack containing all relevant bands (Sigma0_VV and Sigma0_VH) has
to be created. However, our Sentinel-1 pre-processed data contain also the texture bands we used in
the classification. To solve this issue, a graph that selects the appropriate bands from each product
and then stack them together was used. For convenience, the product is already created. Go to File > Open Product navigate to the following path and open the product S1_Stack.dim
Path: /shared/Training/LAND07_DeforestationMonitoring_Paraguay/AuxData/
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Right click on the product and select Open RGB Image Window. Choose the temporal profile you
prefer to visualize the deforestation evolution. The image below shows the following composition:
Red: Sigma0_VH_20180113 | Blue: Sigma0_VH_20180606 | Green: Sigma0_VH_20181121
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QGIS Visualization

Finally, we will visualize the evolution of the deforested area in QGIS. Minimize SNAP and open QGIS
(Applications -> Processing -> QGIS Desktop). Click on the Add Raster Layer button located in the left
panel ( ), navigate to the following path, open the five GeoTIFF files we just created in the previous
step and click Open. Make sure they are displayed in chronological order (most recent down).
Path: /shared/Training/LAND07_DeforestationMonitoring_Paraguay/Processing/
The classification product is open as a singleband gray raster file. To change the visualization, right
click on the first layer (2017-06-11) file and select Properties.
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Select the Style tab on the left panel and choose the following parameters:
Render type: Singleband pseudocolor

Mode: Equal Interval

Classes: 2

Min / Max: 0 / 1

Press Classify. You can choose your own colors or use a predefined color palette. Press the Load Color
Map icon (

), navigate to the following path, select Color_QGIS_1.txt and click OK.

Path: /shared/Training/LAND07_DeforestationMonitoring_Paraguay/AuxData/

For the remaining images, repeat the same procedure and open the following color palettes
respectively. Color_QGIS_2.txt, Color_QGIS_3.txt, Color_QGIS_4.txt, Color_QGIS_5.txt
Finally, load the raster S2_NDVI.tiff and S1_Stack_RGB.tiff to add a basemap layer. (See

NOTE 12).
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NOTE 12: In this example, value 0 refers to the forest area and value 1 to the deforested area. Check to
which category the values correspond in the Color Manipulation tab in SNAP. In case they are inverted
during your classification, the colors will appear inverted here as well. (e.g. the forest area in the first
image will be white instead of red).

THANK YOU FOR FOLLOWING THE EXERCISE!
10 Further reading and resources
Sentinel-1 User Guide
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar

Sentinel-1 Technical Guide
https://sentinel.esa.int/web/sentinel/technical-guides/sentinel-1-sar

Breiman, L. (2001). Random Forests. Machine Learning, 45, 5–32, 45(1), 5–32.
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RUS-Copernicus
RUS Copernicus Training
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RUS-Copernicus Training website
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