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Did you find this material useful?
Authors would be glad to receive your feedback or suggestions and to know how this material was
used. Please, contact us on training@rus-coperenicus.eu
Enjoy RUS!

This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0
International License.
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Introduction to RUS

The Research and User Support for Sentinel core products (RUS) service provides a free and open
scalable platform in a powerful computing environment, hosting a suite of open source toolboxes
pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel
satellites constellation.
In this tutorial, we will employ RUS to identify and map an oil spill in the south of Kuwait using
Sentinel-1 satellite-borne SAR data.
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Oil spill mapping – background
Ocean pollution due to oil spills remains a major
environmental hazard. Although oil tanker
accidents are well known, they are not the main
cause for this type of event. Illegal discharges from
ships or offshore platforms, drilling rigs, pipeline
accidents or natural leaks amongst others bring
together most of the sources for oil pollution in the
ocean.

Last August 10th 2017, an oil spill was reported in
the south of Kuwait, near the Al Khiran area where
Oil spill near Al Khiran, Kuwait. Credits: Kuwait
Environment Public Authority
the Al Khafji offshore oil field is located. While the
cause of the incident is not clear (tanker offshore, pipeline damage), almost 132500 liters have been
leaked based on conservative estimations made by SkyTruth, a non-profit organization based on the
United States.
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Training

Approximate duration of this training session is one hour.
The Training Code for this tutorial is OCEA03. If you wish to practice the exercise described below
within the RUS Virtual Environment, register on the RUS portal and open a User Service request
from Your RUS service > Your dashboard.
3.1
•

Data used
One Sentinel-1A IW GRD
https://scihub.copernicus.eu/

image

acquire

on

10/08/2017

[downloadable

at

@

S1A_IW_GRDH_1SDV_20170810T024714_20170810T024738_017855_01DEF7_F48C

•

3.2

Pre-processed data stored locally
@shared/Training/OCEA03_OilSpill_Kuwait/AuxData
Software in RUS environment
Internet browser, SNAP + Sentinel-2 Toolbox, QGIS
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4.1

Step by step
Data download – ESA SciHUB

In this step, we will download the Sentinel-2A level 2A image from the Copernicus Open Access Hub
using the online interface.
Go to https://scihub.copernicus.eu/

Go to Open HUB. If you do not have an account please sign up in the upper right corner, fill in the
details and click register.

You will receive a confirmation email in the account you have specified: open the email and click on
the link to finalize the registration.
Once your account is activated – or if you already have an account – log in.
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Switch the rectangle drawing mode to pan mode by clicking on the icon in the lower left corner of
the map (Green arrow) and navigate to Kuwait (approximate area – blue rectangle).

Switch to drawing mode and draw a search rectangle approximately as indicated below. Open the
search menu by clicking to the left part of the search bar ( ) and specify the parameters below.
Press the search button ( ) after that.
Sensing period: From 2017/08/10 to 2017/08/10
Check Mission: Sentinel-1
Product type: GRD
Sensor Mode: IW
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The search returns one result. Download the following scene by clicking on the download icon.
Image ID: S1A_IW_GRDH_1SDV_20170810T024714_20170810T024738_017855_01DEF7_F48C
Move the downloaded scenes (desktop, /home/rus/Downloads) to the following path and unzip it.
Path: shared/Training/OCEA03_OilSpill_Kuwaitl/Original

4.2

SNAP – open and explore data

Open SNAP (Applications -> Other). To import the Sentinel-1 image, click File -> Open product (
navigate to the following path and open the product by double clicking on it.

),

Path: shared/Training/OCEA03_OilSpill_Kuwai/Original
File: S1A_IW_GRDH_1SDV_20170810T024714_20170810T024738_017855_01DEF7_F48C.zip
The opened product will appear in Product Explorer. Click + to expand the contents of the file, then
expand the Bands folder and double click on the Amplitude_VV band to visualize it.
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4.3

Subset

To reduce the processing time of the algorithm, we subset the image to our area of interest. Click on
Raster -> Subset. Set the following parameters in the pixel coordinates tab and click OK.
Scene start X: 3065 Scene start Y: 3659 Scene end X: 8861 Scene end Y: 7208

The subset product will be created immediately but it is not saved on your hard disk. Right click on
the subset product (index [2]) and select Save Product. Set the Output folder to the following path
and click Save. Then, click + to expand the contents of the file, expand the Bands folder and double
click on the Amplitude_VV band to visualize it
Path: shared/Training/OCEA03_OilSpill_Kuwait/Processing
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4.4

Speckle filter

To reduce the usual salt and pepper like texturing of SAR images (See
NOTE 1), a speckle filter is
needed. Click on Radar -> Speckle Filtering -> Single Product Speckle Filter.
NOTE 1: Speckle noise-like feature is a common phenomenon in SAR systems. It confers to SAR images a
granular aspect and random spatial variation. The source of this noise is attributed to random
interference between the coherent returns. The principle of speckle filtering is to reduce the variance of
the complex speckled scattering and improve the estimate of the unspeckled scattering coefficient.

In the I/O Parameters, select as input the subset product created previously (index [2]) and set the
output folder to the following path. In the Processing Parameters tab, all the settings remain as
default. Click Run and display the result afterwards. Click + to expand the contents of the file (index
[3]), then expand the Bands folder and double click on the Amplitude_VV band to visualize it.
Path: shared/Training/OCEA03_OilSpill_Kuwait/Processing
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4.5

Oil spill profile plot

To visualize how an oil spill affects the reflectance of the SAR signal we can display a profile of the
sigma nought (σ0) value in the VV polarization mode. Click the line drawing tool icon –
and draw a
line trhough the oil spill that starts and ends in a non-oil spill area.

Click on Analysis -> Profile Plot. Change the Box size parameter to adjust the graph and analyze it.

4.6 Oil Spill Mapping
To identify oil spills in the ocean, we will use Sentinel-1 data (See
NOTE 2) and the dedicated tool
that SNAP offers for this purpose. However, it has to be highlighted that only ‘possible oil spills’ are
detected since some specific oceanic conditions can generate similar visual patterns to the ones of an
oil spill (See
NOTE 3).
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NOTE 2: The all-weather and day-and-night sensing capabilities, spatial coverage, revisit time, and
scattering of the SAR signal are some of the features that allow the use of Sentinel-1 as source of
information for an oil spill surveillance program. The backscatter of the SAR signal over the ocean is
mainly a result of sea roughness (i.e. short gravity-capillarity waves). Oil films decrease the sea surface
roughness and hence the backscatter. This cause spills to appear darker in SAR images than spill-free
areas. However, the contrast between polluted and non-polluted areas depends on different
parameters such as wave height, wind speed, type of oil and sensor characteristics (wavelength,
polarization, incident angle).
NOTE 3: SAR imagery over oceans usually contains oceanic and atmospheric phenomena referred to as
look-alikes that can cause false alarm detections. They dampen the short waves and create dark patches
on the surface, originating problems to distinguish them from oil spills. Look-alikes include natural
films/slicks, grease ice, areas with specific wind speed, rain cells, internal waves, etc.

(a) Verified oil spill on a SAR image. (b) Verified look-alike on a SAR image (Stathakis et al., 2006)

Click on Radar -> SAR Applications -> Ocean Applications -> Oil Spill Detection. The tool includes some
preprocessing steps such as land masking and calibration and the required algorithm to identify
possible oil spills (See
NOTE 4). Follow the instructions to complete the parameters of each tab.
-

Read  select the speckle filtered product (index [3].
Land-Sea-Mask and Calibration  all the parameters remain as default.
Oil-Spill-Detection  Select only the Sigma0_VV as source band. Set the Background Window
Size to 1400 and the Threshold Shift (dB) to 3.5
Oil-spill-clustering  the parameter remains as default
Write  set the output name to ‘Oil_Spill_detection_spk_1400_3_5’ and select the
following path as directory: shared/Training/OCEA03_OilSpill_Kuwait/Processing
NOTE 4: The oil spill detection tool includes two preprocessing steps: mask out the inland areas and
radiometric calibration so that pixel values truly represent the radar backscatter of the reflecting
surface. After those preprocessing steps, dark spots are detected using an adaptive threshold algorithm
where the local mean backscatter level is estimated using pixels in a large window. Then, a threshold is
set to ‘k’ decibel below the local mean calculated before. Pixels within the window with values lower
than the threshold are detected as dark spot. Finally, the detected pixels are clustered into a single
cluster and those with sizes smaller than a predefined size selected by the user are eliminated.
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The output product is created as a binary mask that can be found on the ’Bands’ or ‘Masks’ folders of
the product [4]. Expand the bands folder and open the Sigma0_VV band. To improve the visualization
and contrast, we can transform the pixel values using the decibels scale. For that, right click on the
band Sigma0_VV and select Linear to/from dB. The image will be created and store as a virtual band.
To save it, right click on the band Sigma0_VV_db and select Convert band. Then, double click on it to
visualize it.
To have a better visualization of the oil spill mask, display it on top of the SAR image. For that, open
the Layer Manager (Layer -> Layer Manager), expand the ‘Mask’ folder and check the
Sigma0_VV_oil_spill_bit_msk_detection band.
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4.6

Ellipsoid correction

After the oil spill detection is completed, we can reproject our data into a specific coordinate
reference system. To perform this step, we will use the Ellipsoid Correction (See
NOTE 5).
NOTE 5: Amongst the different options to perform geometric corrections in SANP we use in this case the
ellipsoid correction and not the Range Doppler Terrain Correction. Since our study area is over the
ocean, there are not topographic variations that can lead to geometric distortions of the SAR
backscatter.
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Click on Radar -> Geometric -> Ellipsoid Correction -> Geolocation Grid
On the I/O Parameter tab, select the oil spill detection product (index [4]) and make sure to select
the correct output path: shared/Training/OCEA03_OilSpill_Kuwait/Processing. Then, click on the
Processing Parameters tab, select the UTM / WGS 84 (Automatic) projection and click Run.

Follow the same procedure as before to produce the final visualization.
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5.1

Extra steps
Visualization in QGIS (update using google plugn in)

To export the result to QGIS, we will first change the color of the oil spill mask. Expand the
reprojected product (index [5]), open the ‘Bands’ folder and open the Sigma0_VV_oil_spill_bit_msk.
Click on the Colour Manipulation tab (bottom left corner) (or View -> Tool Windows -> Colour
Manipulation), select the Table editor and set all the colours to red.
Once the colour has changed, right click over the image. Select Export View as Image. Select the
following path to save the product, choose the option Full Scene in the image region section and
write Oil_Spill_Detection as name. Then, click Save.
Path: shared/Training/OCEA03_OilSpill_Kuwait/Processing

Minimize SNAP and open QGIS (Applications -> Education -> QGIS Desktop). Press the Add Raster
Layer button ( ). Navigate to the following path and select the Oil_Spill_Detection GeoTIFF file. Click
Open.
Path: shared/Training/OCEA03_OilSpill_Kuwait/Processing
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For further analysis, you can add auxiliary data such as ocean, land and highways layers. Press the
Add Vector Layer button ( ), navigate to the following path and add the following shapefiles:
kuwait_highways.shp, KWT_admn0.shp and Ocean.shp.
Path: shared/Training/OCEA03_OilSpill_Kuwait/AuxData
Finally, you can also use the ‘OpenLayers plugin’ (See
NOTE 7) to display the result using
OpenStreetMap as background map. Click on Web -> OpenLayers plugin -> Google Maps -> Google
Streets.

NOTE 7: If you do not have the ‘OpenLayers’ plugin install, click on the menu Plugins -> Manage and
install plugins. Select the ‘All’ section on the right side panel, write ‘openlayers’ on the search box,
select the ‘OpenLayers Plugin’ and click install.
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5.2

Download/Upload Virtual Machine/Local Computer

To download outputs from the RUS Virtual Machine to your local computer press Ctrl+Alt+Shift in
your keyboard. A pop-up window will appear on the left side of the screen. Click on bar below
Devices. The folder structure of your VM will appear. Navigate to the path where the file you are
interested in is located and double click on it to download it. In case you want to download a folder,
you will have to zip it beforehand.

THANK YOU FOR FOLLOWING THE EXERCISE!
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Further reading and resources

Sentinel-1 and oil spill detection - ESA
European Maritime Safety Agency (EMSA)
Brekke, C., & Solberg, A. H. S. (2005). Oil spill detection by satellite remote sensing. Remote Sensing
of Environment, 95(1), 1–13. https://doi.org/10.1016/j.rse.2004.11.015
Schistad Solberg, A. H., Storvik, G., Solberg, R., & Volden, E. (1999). Automatic detection of oil spills in
ERS SAR images. IEEE Transactions on Geoscience and Remote Sensing, 37(4), 1916–1924.
https://doi.org/10.1109/36.774704
Stathakis, D., Topouzelis, K., & Karathanassi, V. (2006). Large-scale feature selection using evolved
neural
networks
(Vol.
6365,
pp.
636513–636519).
Retrieved
from
http://dx.doi.org/10.1117/12.688149
Topouzelis, K., & Singha, S. (2016). Oil Spill Detection: Past and Future Trends. ESA Living Planet
Symposium, SP-740(July).
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@RUS-Copernicus
RUS-Copernicus
RUS-Copernicus
RUS Copernicus Training
RUS-Copernicus website
website
RUS-Copernicus Training website
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