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Enjoy RUS!
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International License.
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Introduction to RUS

The Research and User Support for Sentinel core products (RUS) service provides a free and open
scalable platform in a powerful computing environment, hosting a suite of open source toolboxes
pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel
satellites constellation.
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Ocean color monitoring – background
Ocean colour refers to the hue of the
water caused by the presence of tiny
plants containing the pigment chlorophyll,
sediments and colored dissolved organic
material.
From satellite observations in the optical
part of the spectrum we can estimate the
concentrations of different constituents
(pure water, chlorophyll, sediments,
colored dissolved organic matter) provided
we know their effect on the spectral
response of the water (inherent optical
properties - IOPs).

Source: NASA

Chlorophyll concentrations are perhaps of
most interest to us as they are indicators
of algal blooms. Phytoplankton blooms
occur naturally in areas with high nutrient
concentrations (coastal areas – nutrient
runoff from land). When phytoplankton
cells die, they sink to the seabed where
they are decomposed by bacteria
requiring oxygen.

In extreme cases (eutrophication), this
process can result in oxygen depletion
(hypoxia) and the creation of “dead zones”
where all marine life either died or left the
area. While the occurrence of such zones
Source: Teach Ocean Science (http://www.teachoceanscience.net)
on periodic basis is natural, they have
been observed more often and affecting larger areas in the past few decades. This is mainly
attributed to nitrogen and phosphorous from agricultural runoff, but sewage, vehicular and industrial
emissions play a role.
The study area for this exercise will be the southern part of the North Sea. Eutrophication and
hypoxia have been increasingly observed in the coastal areas and the countries surrounding the
North Sea have been working together for the past few decades to reduce pollution runoff.
Monitoring of the chlorophyll concentrations is an important input to assessing these efforts.
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3

Training

Approximate duration of this training session is one hour.
3.1
•

Data used
One Sentinel-3A level 1 image acquired on 5 September 2017 [downloadable @
https://coda.eumetsat.int OR
S3A_OL_1_EFR____20170709T095455_20170709T095755_20170710T143005_0179_019_350_1980_MAR_O_NT_002

•

One Sentinel-3A level 2
https://coda.eumetsat.int]

image acquire on 5 September 2017 [downloadable @

S3A_OL_2_WFR____20170709T095455_20170709T095755_20170710T163958_0179_019_350_1980_MAR_O_NT_002

3.2

Software in RUS environment
Internet browser, SNAP + Sentinel-3 Toolbox
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Sentinel-3 OLCI

The Sentinel-3 is a multi-sensor mission comprising of two satellites (Sentinel-3A and Sentinel-3B) in
identical orbit with a phase shift of approximately 140°. Sentinel-3A has been in orbit since February
2016 and the launch of its twin Sentinel-3B is planed for spring 2018. The missions's main objective is
to measure sea-surface topography, sea- and land-surface temperature and ocean- and land-surface
colour with accuracy in support of ocean forecasting systems, and for environmental and climate
monitoring. It provides Near-real time data for ocean forecasting, sea-ice charting, and maritime
safety services on the state of the ocean surface, including surface temperature, marine ecosystems,
water quality and pollution monitoring.

Sentinel-3 sensors (Credits: Sentinel-3 SLSTR User Guide, ESA)

The Ocean and Land Colour Instrument (OLCI) is a medium-resolution imaging spectrometer that
uses five cameras to provide a wide field of view (swath width: 1270 km). It provides 21 bands,
ranging from the visible to the near infrared (400 – 1020 nm), acquired simultaneously with
approximately 300 m spatial resolution. The revisit frequency of single satellite is approx. 3.8 days at
the equator and it will be halved once the second satellite of the constellation becomes operational.
3

5
5.1

Step by step
Data download – ESA SciHUB

In this step, we will download the Sentinel-3A Level-1 product and a corresponding Level-2 WFR
(Ocean product) product from the EUMETSAT Copernicus Online Data Access using the online
interface.
Go to https://coda.eumetsat.int/

Click OK. You will be redirected to a login page. If you do not have an account, please register in the
upper right corner and login.
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Switch the rectangle-drawing mode to pan mode by clicking on the icon in the upper right corner of
the map and navigate to the north of the Scandinavian Peninsula.
Switch to drawing mode and draw search rectangle approximately as indicated below. Open search
menu by clicking to the left part of the search bar and specify the following parameters:
Sensing period: From 2017/09/05 to 2017/09/05
Check Mission: Sentinel-3
Instrument: OLCI
Timeliness: “Non Time Critical”

In our case, the search returns 2 results depending on the exact search area defined. Download
scenes:
S3A_OL_1_EFR____20170709T095455_20170709T095755_20170710T143005_0179_019_350_1980_MAR_O_NT_002
S3A_OL_2_WFR____20170709T095455_20170709T095755_20170710T163958_0179_019_350_1980_MAR_O_NT_002
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Move the downloaded scenes from /home/rus folder to
/shared/Training/OCEA04_OceanColour_S3_TutorialKit/Original
Then right-click on each of the zipped products in turn and go to “Extract Here”.
5.2

SNAP – open and explore data

In Applications -> Other open SNAP Desktop; click Open product , navigate to
/shared/Training/OCEA04_OceanColour_S3_TutorialKit/Original
Navigate to each of the extracted product folders and open xfdumanifest.xml to load the product to
SNAP.
The opened products will appear in Product Explorer tab in the upper left part of the window. Right
click on the Level-1 product (S3A_OL_1_EFR…) and select Open RGB Image Window to create and
visualize RGB composition image.
Set:
Red: 0a08_radiance
Green: 0a06_radiance
Blue:

0a04_radiance

Click OK.

You can see that the View is very dark, so let’s enhance it a bit. Go to the Color Manipulation tab in
the lower left corner of the SNAP window. Here we have to change the histogram stretch for each of
the RGB component bands. Check that the Red histogram is shown and click on the right-hand slider
below the histogram. Move it to approx. 70. Change the histogram to green at the top of the tab and
set the slider to approx. 70. Last, change the histogram to blue and set the slider to approx. 90.
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5.3

Subset

The majority of our image is covered by land or cloud and does not contain any valuable information
for our purposes, so let’s subset it to a smaller area of interest. Make sure the Level-1 product is
selected (highlighted) in the Product Explorer tab. Go to Raster -> Subset. In the Spatial Subset tab
go to Pixel Coordinates tab and set following coordinates:
Scene start X:
Scene start Y:
Scene end X:
Scene end Y:

850
2150
2800
4090

The subset area is indicated by the blue rectangle on
the left of the dialog window. Click OK.
A subset product with index number [3] was created in
the Product Explorer tab. Let’s open the RGB view in
the same way we have done for the full product and
enhance the histogram.
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5.4

C2RCC Processor

The Case 2 Regional CoastColour processor, originally developed by Doerffer and Schiller for the
MERIS sensor, and improved through the ESA DUE CoastColour project (Brockmann et al., 2016). It is
applicable to all past and current ocean colour sensors (such as S3) as well as Sentinel-2. It has been
validated in various studies and is available through ESA’s Sentinel toolbox SNAP. It is also used in the
Sentinel-3 OLCI ground segment processor of ESA for the generation of the Case 2 water products.
We will use it here to reproduce the Level-2 Water product that we have also downloaded. For more
information about the processor refer to
NOTE 1).
To run the processor, go to Optical -> Thematic Water Processing -> C2RCC Processors -> OCLI. You
can see that the processor is available for variety of different sensors.

In the I/O Parameters tab make sure that the subset product with index number [3] is selected as
source OLCI L1b product. The original name of the S3 product is quite long so let’s replace it with
8

something more manageable. In the Target Product section,
Subset_S3A_OL_1_EFR_20170709T095455_C2RCC and set output Directory to:
/shared/Training/OCEA04_OceanColour_S3_Tutorial/Processing

enter

Name:

In the Processing Parameters tab check the salinity and temperature values. These variables among
others are used to determine the absorption and scattering of pure water. For salinity, we will set
value of 34.6 PSU and surface temperature of 15°C match well with our study area in beginning of
July.

Sea Surface Salinity SST (Dataset : JPL SMAP Level 3 CAO Sea surface Salinity Standard Mapped Image 8-Day Running mean
V3.0 Validated dataset) for 8 July 2017. Left: spatial variability; Right: study area SST average value; Source: JPL Climate
Oceans and Solid Earth group. 2017)

We can ignore the Ozone and Air Pressure values and they will not be used, instead total ozone and
sea level pressure grids available in the OLCI L1b products (ECMWF auxiliary met data) will be used.
This option must be ticked below ( Use ECMWF aux data of source product).
The other parameters define the arithmetic relationship between inherent optical properties (IOPs)
of the water constituents (absorption by pure water, phytoplankton pigments, yellow matter, etc.)
and the actual concentrations of chlorophyll and total suspended matter. We will leave all default
values as these have been widely tested and validated and are also used to derive the S-3 Level 2
product.
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The only parameter we will change in the Processing Parameters tab will be the Valid-pixel
expression. To edit the default expression click on the three dots next to the text window (indicated
above by arrow). Based on the default expression pixels is valid if the invalid flag is false as well as
the land flag with the exception of inland water bodies. We will change the expression to exclude
also pixels flagged as sun glint risk and remove the inland waterbodies. To achieve this we set the
expression to (! == NOT):
!guality_flags.invalid && !guality_flags.land &&
!guality_flags.sun_glint_risk
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Click OK and then click Run to execute the C2RCC processor. This might take up to 10 minutes
depending on your VM/PC. Once the processing has finished and notification window will appear,
click OK. In your Product Explorer tab, you will find a new product with index number [4].
5.5

Visualization

Now let’s see our outputs. Expand the new product in the Product Explorer and for to the Bands
folder. In the Bands folder, you will find 7 folders and four additional bands.
The first folder iop contains the absorption coefficient bands for different water constituents at 443
nm. The second folder conc contains the absolute concentration bands for total suspended matter
dry weight (conc_tsm [g*m-3]) and chlorophyll concentration (conc_chl [mg*m-3]). The next folder we
are interested in is the rhown containing the Normalized water-leaving reflectances for each original
radiance band (See
NOTE 1). Lastly, we need to pay attention to the unc folder containing
uncertainty estimates for the IOPs and the concentration bands.
NOTE 1: Radiance is the variable directly measured by remote sensing instruments. It is the amount of
light seen by instrument from a surface of an object. In the SLSTR products is given as radiance of a
-2
-1
-1
surface per unit wavelength [mW*m *sr *nm = watt per square meter per nanometer].
Reflectance is the ratio (percentage) of the amount of light leaving a target to the amount of light
arriving to the target. It has no units. It is the property of the observed object/material.

Let’s expands the conc folder and double click on conc_chl band to open it in view window.

We ca see that all the land areas have been removed (set to noData) but clouds appear are
misclassified as high concentration. We can use the masks included in the product to eliminate them.
Go to View -> Tool Windows -> Mask Manager. The Mask Manager window should appear docked
to the right side of the snap window. There you can enable flags indicating land (guality_flags_land green) and Cloud_risk (gray). You may need to zoom-in and out to load the masks properly.
IMPORTANT! The masks do not remove the values corresponding to clouds from the histogram; they
only hide them from view.
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You can also inspect the uncertainty of these concentration estimates. Go to the unc folder and open
the unc_chl band. You can again use the masks to mask out the cloud values.

You can also explore the total suspended matter estimates. Open the conc_tsm (use the cc_tsm.cpd
colour pallete to visualize), investigate also the unc_tsm.
Close all views except the conc_chl view.
5.6

Comparison to the Level-2 WFR product

In the beginning of the exercise, we have downloaded two products, Level-1 EFR product that we
have processed and Level-2 WFR product. Now let’s compare our output to the operationally
generated.
In Product Explorer highlight the Level-2 product (index number 2), then go to Raster -> Subset and
subset the product using the same pixel coordinates as for the Level-1 product.
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Scene start X: 850
Scene start Y: 2150

Scene end X:
Scene end Y:

2800
4090

Then expand the newly created subset product with index number [5], navigate to Bands -> CHL and
open the CHL_NN band. Again, go to the Colour Manipulation tab and load the cc_chl.cpd colour
palette. Click NO to keep the predefined color classes.
Then open the Mask Manager and turn on the WQSF_lsb_LAND mask as well as all the cloud related
masks (WQSF_lsb_CLOUD, WQSF_lsb_CLOUD_AMBIGUOUS, WQSF_lsb_CLOUD_MARGIN), in the
Transparency column change the transparency to 0.
Go to Window -> Tile Horizontally; in Navigation tab select Zoom all.

You can also open the uncertainty bands and compare them. You will see some minor differences
mostly due to the additional preprocessing applied during the generation of the Level-2 WFR product
by the ground segment. These preprocessing steps are not applied to the Level-1 product we have
processed and are not part of the C2RCC algorithm.
5.7

Export as GeoTIFFs

Close all view windows. In Product Explorer expand the Level-1 processed product [4], navigate to
Bands -> conc right-click on the conc_chl band and select Convert Band (this converts the band from
virtual to physical so we can export it.). Do the same for the unc_chl band. Right-click the product
name and select Save Product.
Go to File -> Export -> GeoTiff (NOT! Geotiff/Big Tiff). In the dialog, that opens click Subset -> Band
Subset (second tab) and select only bands conc_chl and unc_chl (use the Select none button to
deselect all), then go to the Metadata Subset tab and click Select none. Then click OK and save the
file as Chlorophyll_conc_20170709.tif to the Processing folder. In the dialogs (one or two), that
appear, click No.
Repeat the same for the TSM bands (save as TSM_20170709.tif).
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Now, we can import the image to another GIS/ Remote sensing software for further processing or
map creation (section 6.3 Convert to vector). In the extra steps of this tutorial, we will use QGIS. To
download the results to your local computer see section 6.2 Downloading the outputs from VM.

6
6.1

Extra steps
Downloading the outputs from VM

Press Ctrl+Alt+Shift. A pop-up window will appear on the left side of the screen. Click on bar below
Devices, the folder structure of your VM will appear. Navigate to your Processing folder and double
click any file you want to download.
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THANK YOU FOR FOLLOWING THE EXERCISE!
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