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Introduction to RUS

The Research and User Support for Sentinel core products (RUS) service provides a free and open
scalable platform in a powerful computing environment, hosting a suite of open source toolboxes preinstalled on virtual machines, to handle and process data derived from the Copernicus Sentinel
satellites constellation.
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Introduction to BRAT

The Broadview Radar Altimetry Toolbox is a tool designed to use radar altimetry data. The toolbox is
able to:
•

Read all altimetry data from official data centres, from ERS-1 and 2, Topex/Poseidon, Geosat
Follow-on, Jason-1, Envisat, Jason-2, Cryosat and Sentinel-3, from Sensor Geophysical Data
Record to gridded merged data.

•

Do some processing and computations.

•

Visualise the results.

BRAT is an open source software with a GPL-3 license type. Its source code is publicly available on-line
in a dedicated GitHub repository. Contributions from the altimetry community to the code are
encouraged and everyone can propose new code to be committed to the master branch via the pull
requests feature from GitHub.
BRAT can be downloaded along with a Radar Altimetry Tutorial at http://www.altimetry.info/.
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Training - Proposed Exercises

Approximate duration of this training session is one hour.
The Training Code for this tutorial is OCEA07. If you wish to practice the exercise described below
within the RUS Virtual Environment, register on the RUS portal and open a User Service request from
Your RUS service → Your dashboard.
The following BRAT exercises will deal with:
•
•
•

The impact of a Typhoon the estimates
Global and Mean Sea Level Anomaly
Geostrophic currents & Current Speed
Data used

•

2 Official Sentinel-3 SRAL L2 WAT products [https://coda.eumetsat.int/#/home] and stored
locally @/shared/Training/OCEA07_Oceanography_TutorialKit/Original/S3_data

•

CMEMS L3 along-track Sentinel-3 products (Global & Regional) [http://marine.copernicus.eu/]
stored locally @/shared/Training/OCEA07_Oceanography_TutorialKit/Original/CMEMS_data

•

Pre-processed data [http://www.esa-sealevel-cci.org/products] stored locally
@/shared/Training/OCEA07_Oceanography_TutorialKit/Original/SLCCI_data
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Software in RUS environment
BRAT, SNAP
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Register to RUS Copernicus

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as
a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on
Login/Register in the upper right corner.

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus
Users’ Single Sign On Registration. Click Register.

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the email to activate your account.
You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter your
chosen credentials.
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Upon your first login you will need to enter some details. You must fill all the fields.
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Request a RUS Copernicus Virtual Machine

Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise
or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service →
Your Dashboard.
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that
the appropriate cloud environment can be assigned according to your needs.

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the
appropriate field.

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your
request once you are finished.
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email
with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your Dashboard
and click on Access my Virtual Machine.
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access
your RUS Copernicus Virtual Machine.

This is the remote desktop of your Virtual Machine.
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Background on Radar Altimetry

Altimeters measure the range between the satellite and the sea surface observed at nadir (i.e. in the
vertical direction pointing the direction of the force of gravity):
A reference ellipsoid shall be considered as baseline Datum (e.g. WGS84).
The satellite flies along the orbit in the along-track direction.
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The orbit is typically determined with an
accuracy (radial orbit error) of <2 cm by using
SLR, GPS and DORIS data (10-100 m in ’50s-’60s
with optical data & 5-10 cm in current Near Teal
Time, NRT, and Standard Time Critical, STC, L2
products discussed later).
Geoids (i.e. the ocean surface excluding the
influence of wind and tides) are obtained from
other missions (e.g. GRACE, GOCE). No accurate
oceanographic information can be obtained
without an accurate geoid.
The range measurement shall be corrected for a
series of effects related to the propagation into
the Ionosphere/Troposphere, the instrument
and the surface. We can write:
Sea Surface Height (SSH): Satellite_Altitude - Corrected_Range.
Dynamic Topography: Mean Dynamic Topography (MDT) + Sea Level Anomaly.
These quantities will be discussed in detail during the BRAT exercises. The aforementioned corrections
are summarized in the figure below:

The resolution of the altimetry products will be discussed in the following 3 directions:
•

Along-track direction: It is the direction of flight of the platform (blue box).

•

Across-track direction: It is the direction perpendicular to the direction flight of the platform
(red box).

•

Nadir direction: vertical direction pointing the direction of the force of gravity (green box). The
resolution in this direction is dictated by the bandwidth (350 MHz for the SRAL altimeter on
board Sentinel-3) and is named range resolution (Res_range = speed_of light / 2 * Bandwidth
= 0.43 m)

In general, the resolution indicates the capability of a system to sample the space in a direction. The
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higher it is (lower in value) the better it is to study short scales phenomena, small water bodies (e.g.
rivers & lakes) and retrieve the ocean surface parameters with the accuracy needed for oceanography
studies (around 2 cm).

This scheme shall be considered only for the purpose of understanding these 3 directions. Altimetry
sensors are in fact nadir-looking sensors and not side-looking as indicated in the figure.
Present, past and future altimetry missions are reported here:

The processing schemes that are currently adopted in radar altimetry are the Low Resolution Mode
(LRM) & the Synthetic Aperture Radar (SAR) mode. These will be discussed in the next sections.
Sentinel-3 and Cryosat-2 missions operate the SAR mode. CryoSat-2 also includes LRM & SARin modes
(in SARin two antennas are available for interferometry). All other missions are in LRM mode.
In the future, a new pulse transmission mode designed for Sentinel-6/Jason-CS will allow to obtain
simultaneously SAR and LRM waveforms.
Processing schemes: Low Resolution Mode
Adopts a pulse limited acquisition. The pulse, propagating along the nadir direction as a spherical wave,
strikes the surface and controls the area on ground from which the backscattering occurs (red area)
over time. The time on target dictated by the beam illumination (blue area) during the overfly of a
surface location is not exploited. The returned power (bottom panels) is typically formed by a flat
region (noise, no power received power), a leading edge created by the first reflection up to the
formation of the pulse limited footprint and the trailing edge related to the formation of annuli on
ground whose backscattered power is constant but results attenuated by the non-constant gain at the
border of the antenna pattern. The output LRM waveform is known in products as the L1b waveform.
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Observed parameters:
•

Significant Wave Height (SWH): It is defined traditionally as the mean wave height (trough to
crest) of sea waves and is related to the slope of the leading edge in the L1b waveform. The
degree of steepness of the leading edge is related to the sea state (flat, SWH around 1m, or
rough sea surface, typically 2m < SWH < 8m).
• Range: related to the mid-height value of the leading edge. It is independent from SWH.
• Wind Speed (Power): related to the maximum received power at the end of the leading edge.
Key points:
•

Along/Across track resolution: several km depending on the significant wave height (SWH).
Typical values are from 2 km (SWH = 2m) to 12 km (SWH = 10m)
• All estimates (SWH, Range, Wind Speed) are retrieved from the leading edge.
• A huge amount of power is wasted in constructing the trailing edge. This will not contribute to
the retrieval of the estimates. This power is collected from the border of the antenna footprint
(blue area).
• The transmitted pulse fully controls the creation of the echo, this is why this is also known as
“the pulse limited mode”.
The next figure relates the observed parameters with the received power.
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Processing schemes: Synthetic Aperture Radar
The time on target, dictated by the beam illumination and
movement of the platform over the point, and the Doppler effect in
the along-track direction are exploited in SAR mode.
A burst of pulses is transmitted (Sentinel-3, 66 pulses: 1 C-band
pulse (5.3 GHz) / 64 Ku-band pulses (13.575 GHz) / 1 C-band pulse)
and received.
Differently from the LRM, in which each pulse is received before the
transmission of the next, in SAR, all the returns related to a burst
shall be received before transmitting the successive burst.
Each pulse of the burst interacts as in the LRM mode, the SAR
processing is performed after all data are collected.
The Doppler effect induces a Doppler shift in the received frequency because of the relative motion
between the moving sensor and the fixed point on ground.
The Doppler shift is null at nadir where there is no relative
movement between the satellite and the target point on ground.
The SAR processing takes advantage of the Doppler effect to split
the antenna beam in several beams whose width is related to the
Doppler resolution.
Beams are then steered to specific surface locations. As a result,
considering all the subsequent transmissions during the time on
target, each point on ground results seen though different beams
from different directions. For each surface point, beams are stacked
and multi-looked (incoherently averaged) to reduce the speckle
noise:

As a result, the SNR and along-track resolution are improved in comparison to the LRM mode.
By comparing to the LRM mode waveform construction (first figure of section 6.1), the power coming
from the annuli and creating the LRM waveform trailing edge, is in SAR, collected by the outer beams
(e.g. those colored in pink & red) and will contribute together with all other beams in the stack to
reconstruct the power backscattered in all the investigated directions by the surface point on ground.
The power of the trailing edge, being relocated to the leading edge by the stacking (all beams point
the surface location observed by the nadir beam, the reference), is lower if compared to that in the
LRM waveform. The SNR of the leading edge will therefore improve as depicted later in figures.
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Again, as not only the nadir direction but all the directions allowed by the SAR processing formulation
are considered, the surface state (flat or rough) does not affect the capability of recovering all the
backscattered power (returning at nadir if the surface is flat or distributed in various directions if the
surface is rough).
Therefore, the resolution in the along-track direction is in SAR fixed in value and independent from the
SWH.
Key points:
•
•

The time on target dictated by the satellite speed and beam illumination is exploited.
Along track resolution: improves up to 300 m (independent from SWH). The Doppler effect
can be exploited only in this direction.
• Across track resolution: same as LRM (dependent upon SWH, typically 2-12 Km).
• Higher SNR due to the SAR processing beam segmentation, stacking & integration.
The figure below clarifies the difference of LRM and SAR L1b waveforms underlining the improvement
in SNR (higher leading edge power) and the reduction of power wasted in the trailing edge.

The SAR processing is currently adopted on Sentinel-3 and Cryosat-2. More information about the SAR
processing can be found in this paper:
R. K. Raney, “The delay/Doppler radar altimeter,” IEEE Trans. Geosci. Remote Sens., vol. 36, no. 5, pp.
1578–1588, Sep. 1998. DOI: 10.1109/36.718861
The future of SAR processing is the Fully-Focused SAR developed in the paper “Fully Focused SAR
Altimetry: Theory And Applications” by Egido And Smith (2016) Doi: 10.1109/Tgrs.2016.2607122
•

FF SAR processing can reduce the along-track resolution down to the theoretical limit equal to
half the antenna length (i.e. 0.5 m).

•

The footprint of an FF-SAR altimeter measurement is a narrow strip on the surface, which is
pulse limited across track (LRM mode) and SAR focused along track.

The following figure compares the along- and across-track resolution in the 3 modes:
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The Fully-Focused SAR is not implemented in current altimetry missions.
L1b waveforms
The shape of L1b waveforms acquired in open ocean, depends on the operative mode
(LRM/Conventional or SAR/Delay-Doppler). LRM and SAR L1b waveforms are different and require
different L2 processors (retrackers) to correctly estimate the quantities of interest (range, SWH, wind
speed). L1b waveforms processed over different scenarios (open ocean, coastal zone and inland water)
require different retrackers.

L1b waveforms acquired in the coastal zone can be significantly distorted due to the presence of the
coast in the radar footprint. Moreover, troposphere corrections obtained from the on-board
radiometer are contaminated and models are required. Altimetry estimates from such L1b waveforms
are not reliable and shall not be used without applying filtering criteria. The SAR operative mode (300
m resolution in along-track) allows to acquire more valid waveforms in approaching the coast than the
LRM mode (7 km in along-track). The shape of the waveform can be checked for filtering purposes.
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Jason-2 SIGDR products include LRM L1b waveforms and can be opened in BRAT v.4.2.1 and plotted
creating a video.
Retracking & L2 Products
The Retracking processing is applied on L1b waveforms (SAR, LRM) and can be based on a model
(analytical) or be empirical.
In the Analytical retracking (left image below), the algorithm:
•

Finds the gate of the mid-height of leading edge in the return L1b waveform which is
associated with the range.
• Fits the returned echo to a waveform model corresponding to the observed target (e.g. the
Brown model for rough ocean): Several models will be tested and fitted to the altimeter signal,
by varying SWH, range and power, the best fit will minimize the error according to some
criteria, e.g. the Normalized Residual Error (NRE).
• Corrects the range measurements from the on-satellite tracking algorithm according to the
departure between the mid-gate and original measurement.
The time over which the above LRM L1b waveform is constructed, is sampled in gates whose width is
dictated by the range resolution of the radar in the nadir direction discussed in section 3.
Differently, Empirical retrackers (right image below) (e.g. OCOG, threshold, β retracker) work on the
statistics of the waveform to extract only the leading edge position and the power. In OCOG retracking,
the echo is replaced with a box that has the same center of area as the echo (Center of Gravity - CoG).
The Leading Edge Position (LEP) is taken as the point on the echo that first crosses the amplitude A,
where A is an empirically determined threshold. No functional fitting is applied, it is fast and easy to
implement but less accurate than physical retrackers.

17

L2 products are created after the retracking process and include the estimated SWH (only in the
analytical retracking), range & power (named also sigma0). Geophysical corrections are also included
in the typical output netCDF/binary files.
Estimates are provided with a specific sampling along the track. This is dictated by the operative mode
(SAR, LRM) and by the need of creating accurate products for applications such as oceanography and
coastal/inland water altimetry.
Posting rates in L2 products are the following:
•

1-Hz: from LRM mode (7 km sampling in the along-track direction). Individual L1b waveforms
are averaged over 7 km to obtain a smooth signal suitable for oceanographic estimation (high
accuracy, ~4 cm).

•

20-Hz: from SAR mode (~300 m sampling in the along-track direction, see figure below) or LRM
mode (by averaging a lower number of individual waveforms over 50 ms).

It is important to keep in mind that:
1. In the LRM mode a certain number of individual waveforms is averaged to reduce the speckle
noise, allow the analytical retracking through models expecting smooth waveforms and
produce data with the two posting rates above (1Hz, 20Hz),
2. In the SAR mode, a 20Hz estimate is produced differently by using a Doppler processing which
is able to reduce the footprint to 300 m.
Even if the posting rate can be at 20Hz (300 m) for both SAR and LRM, the along-track resolution of
these estimates is not comparable.
At the moment, SAR mode is operative on Sentinel-3 and Cryosat-2 missions. Many present and all
past missions are in LRM mode. SAR waveforms can be degraded to produce ReDuced-SAR
(RDSAR)/pseudo-LRM waveforms at 1Hz (7-km spacing). A SAR 4-burst cycle is ~ 1 LRM cycle of 50 ms
(20Hz). pLRM mode is used to derive pseudo LRM waveforms from 4 SAR bursts. Therefore, the RDSAR
processing allows to produce data which are not statistically equivalent to LRM data but that can be
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combined with past LRM missions’ data to increase the length of the time series for climate studies.
This demonstrates the effort put in establishing a continuity with previous altimeter datasets.
In the next exercises, both 1Hz & 20Hz data from Sentinel-3 will be considered. Typical Sentinel-3
netCDF products include data at different posting rates (01,20) and from different retrackers (_ice_,
_ocean_,_ocog_,_sea_ice_):

Some other information about the Sentinel-3 mission are reported below:

•

The main objective of the Sentinel-3 mission is to measure: sea surface topography, sea and
land surface temperature, and ocean and land surface colour with high accuracy and reliability
to support ocean forecasting systems, environmental monitoring and climate monitoring.
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•

The satellite orbit provides a 27-day repeat cycle for the topography package. Latitude is up
to 82 degrees (Cryosat-2 reaches 88 degrees).

•

A Sea and Land Surface Temperature Radiometer (SLSTR) to determine global sea-surface
temperatures.

•

An Ocean and Land Colour Instrument (OLCI) is also part of the payload.

•

A dual-frequency (Ku and C band) advanced Synthetic Aperture Radar Altimeter (SRAL) is
based on CryoSat-2 heritage and provides 20 Hz measurements at a resolution of ~300m in
SAR mode along track.

•

SRAL is supported by a microwave radiometer for atmospheric correction and a DORIS receiver
for orbit positioning.

Data are distributed in 3 timeliness (NRT, STC, NTC) according to the accuracy of the orbit:

Sentinel-3 tracks in .kml format (see figure above, right panel) can be downloaded from:
https://sentinel.esa.int/web/sentinel/missions/sentinel-3/satellite-description/orbit
Auxiliary data
Gauges locally measure relative sea level, absolute level if they are referenced to an ellipsoid (e.g.
WGS84) with a GPS.
Tide gauge measurements (e.g. collected every 10 min, every hour…) are made with respect to a local
fixed reference level on land. Local vertical land motion can be corrected by using GPS data.
When reference datums are different, a de-meaning (subtracting the mean from each set of
observations so that they are zero-mean) shall be applied when comparing TG and Altimeter dataset.

In the next figures, the RMS difference of de-meaned water lavel from altimetry and tide gauges as a
function of the search radius around the tide gauges is reported. This kind of analyses can be made by
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considering altimetry estimates acquired in approaching the coast (image credit: ESA/CP4O (left),
ESA/SLCCI-BP (right)).

7

Step by step
Data download – EUMETSAT CODA portal

L2 Sentinel-3 altimetry data from SRAL are available in two types:
•

Land Products “S3A_SR_2_LAN_XXX” (distributed by ESA at https://scihub.copernicus.eu)
including inland water areas & coastal zone.
• Water Products “S3A_SR_2_WAT_XXX” (distributed by EUMETSAT at:
https://coda.eumetsat.int/#/home) including coastal zone & open ocean.
The interface is the same on both websites and lower level products (e.g. L1B data) are available from
both repositories.
In this training we will use Sentinel-3 L2 WAT products from EUMETSAT.
Before starting the exercise, make sure you are registered in the EUMETSAT Copernicus Online Data
Access (CODA) repository so that you can access the free data provided by the Sentinel satellites.
Open an Internet Browser and go to https://coda.eumetsat.int/#/home (Instructions here on how to
download, are given using Internet Explorer).
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If you do not have an account, create an account using the button located in the lower left corner.
Please fill in the details and conclude the registration. Once the registration procedure is over and the
account created, log-in.
Afterwards, access the data catalouge by clicking on the Copernicus Online Data Access section
indicated below:

The data catalogue interface will show up:

For the first series of exercises, we will use two tracks acquired in East China. They are separated by
the repeat cycle of Sentinel-3 (27 days) and have been acquired over the same position on June 9 th
2018 & July 10th 2018 by Sentinel-3A, respectively.
By holding the wheel button, or the right button, move the map to East China and then zoom (wheel
button of the mouse) to obtain the following view:
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To collect the data:
• draw a rectangle indicated below by holding the left mouse button,
• open the search menu by clicking at the left of the search bar ( ),
• specify the following parameters and press the search button ( ):
Sort by: Sensing Date
Sensing period: From 2018/06/09 to 2018/06/09 (1 day)
Check Mission: Sentinel-3
Product type: SL_2_WAT__
Timeless: “Non Time Critical”
Instrument: SRAL
Product Level: “L2”

Select the product:
S3A_SR_2_WAT____20180609T013721_20180609T022139_20180704T173753_2658_032_117____
__MAR_O_NT_003
The track will be highlighted in purple on the map. Click on the arrow icon

to download it.
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Once downloaded (@/home/rus/Downloads), move it to the following path and unzip it (right click
on the product → Extract Here).
Path: /shared/Training/OCEA07_Oceanography_TutorialKit/Original/S3_data
To download the second, change the Sensing period in the query to:
Sensing period: From 2018/07/10 to 2018/07/10 (1 day)
Download the following product, move it to the same path and unzip it there as well.
S3A_SR_2_WAT____20180710T013336_20180710T021747_20180804T173801_2651_033_174____
__MAR_O_NT_003
Other data used in the training are from CMEMS (http://marine.copernicus.eu/) and SLCCI
(http://www.esa-sealevel-cci.org/products) and are already present in the Original folder of the
Tutorial Kit. Data will be discussed in the correspondent sections. Links provided include more
information about the data and on how to download them.
BRAT – Overview
7.2.1

Create a workspace

Open BRAT software from the icon located on the desktop
BRAT GUI.

or go to Applications → Processing →

When you open the BRAT GUI, click on “New” or go to Workspace → New and give a name to it (e.g.
“Webinar”).
Then click on “Browse” and locate the “Workspace” you will use.

0
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Go to “Look in” and set as path: shared/Training/OCEA07_Oceanography_TutorialKit/Processing.
Then click on “Choose” without writing anything at the “Directory” and finally click on “Create”.

A “Workspace” is a way of saving your preferences, computations and generally the work done with
BRAT GUI. Some or all elements of a workspace can be imported into another workspace. The
“Workspace” menu (and also the main toolbar) allow the user to create, open, close, save, import,
rename or delete a workspace.
It is highly recommended to save your workspace (Ctrl+S, or “Save” in the “Workspace” menu) while
working. You will be asked whether or not you wish to save the workspace when you quit BRAT GUI.
NOTE 1: Remember that if you select “No” and have not saved anything previously, none of your work
can be recalled later. BRAT GUI recalls the last used Workspace by default.

7.2.2 Select the Map layer
BRAT offers 3 Main Map Base Layers accessible from Tools → Options → Startup. You can select the
appropriate one and then click OK. You need to restart the software every time you select a layer in
order to apply it and visualise it.
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Example of how a Vector layer looks like:

Raster layer:

For this exercise, choose the second option “Use a raster Layer” click on “OK” and restart the program
(Workspace tab → Exit). At the window dialog that appears: “Do you want to save any workspace
changes?”, click “Yes”.
7.2.3 Understand the BRAT GUI
Open BRAT software again. Using BRAT GUI is basically a 3-step process:
•
•
•
•

Define one or several Dataset(s): the product data you want to work on (see data required in
each exercise, they will be imported from this tab).
Add one or more Filters: this step is optional and allows the creation of data filters (for your
input datasets) using time or location criteria.
Create an Operation (Quick or Advanced): configure the data fields you want to visualize and
respective process parameters that are used for generating the plots.
The Datasets, Filters and Operations tabs are within the 'Workspace Elements' dock.
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Each tab corresponds to a different function, and to a different step in the process, so you have to use
them (‘Filters’ in optional) one after the other.

Preliminary operations
At the beginning of each BRAT exercise, please either delete all data, filters & operations used in the
previous session or delete the entire workspace (fastest and easiest approach):
7.3.1 To delete a Workspace
Click on the Workspace tab and select Delete… . Then click “Delete” at the window dialog as well.

NOTE 2: If you use BRAT for the first time, do not apply this step at this moment since you will delete
the Workspace you have previously created for this exercise.

7.3.2 To delete an operation
Go to the Workspace Elements panel → Operations and click on “Advanced”.
If Filters are present, these shall be disabled by clicking on the filter name
on the Delete operation icon
below).

and then click

. Click on “Yes” when the system messages appear. (Left image

Only the “Quick Operation” shall remain available in the Operations menu. Filters have to be disabled
also for the quick operation in a similar way.
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Sometimes an operation can be cancelled only if the filters associated with the operation are disabled
and deleted (see next section).
NOTE 3: If you use BRAT for the first time, there will be no previous operations stored and you will not
be able to click on “Advanced”. The whole tab will be inactive. (Right image below).

7.3.3

To delete a filter
Filters have to be disabled also for the
operations (Quick/Advanced).
Then, go to the Workspace Elements
panel → Filters
If there is one area or more available in
the “Areas & Regions” list, select them
one by one using the “Selection Tool”
button

and:

1) uncheck all the entries of the “Areas
& Regions” list,
2) click on the “Delete area” button
and on “Yes” when the system message
appears.
If a “Warning” window appear, click OK
and apply the next step.

To delete a filter e.g. “Selected Filter
” click on the delete filter icon
“Yes” when the system message appears. (Left image below).

and then on
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NOTE 4: If you use BRAT for the first time and there are no previous filtered created or stored, the whole
“Filters” tab will be inactive, and you cannot apply this step. (Right image below).

Reminder: The filters have to be deselected from both Quick and Advanced operations before being
cancelled. After the cancellation of the filter, the operation can be cancelled.
7.3.4

To delete a dataset
Go to the Workspace Elements panel
→ Datasets, select the dataset you
want to delete and then click on
“Clear...” icon

.

NOTE 5: If you use BRAT for the first time and there is no previous Dataset created or stored, the whole
tab will be empty, and you cannot apply this step. (See image below).

Exercise n. 4 – The impact of a Typhoon the estimates.
The track used in OCEA06 Training Kit, has been acquired one month before the passage of Typhoon
Maria. Typhoon Maria was a powerful tropical cyclone that affected Taiwan & China.
The typhoon reached its first peak intensity (rightmost figure below; red dots on the right) on July 6,
2018; subsequently, Maria weakened due to an eyewall replacement cycle, but it re-intensified and
reached its second peak intensity on July 8. Later, it started to gradually weaken due to colder sea
surface temperatures. After hitting the Yaeyama Islands and affecting Taiwan on July 10, Maria
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ultimately made landfall over Fujian, China, early on July 11, before dissipating on the next day
(rightmost figure below; orange, yellow and cyan dots on the left).

On July 10th, Sentinel-3 collected data during the typhoon event. To locate the satellite track and the
typhoon, both OLCI (Ocean Land Colour Instrument) providing optical images (see the left-most image
above) and SRAL instruments on-board Sentinel-3 can be used. In the following figure, the OLCI image
geo-located using the SNAP toolbox is reported along with the satellite track. The track intersects the
typhoon at a latitude of around 25 degrees (not crossing the eye of the storm).

NOTE 6: To process OLCI Sentinel-3 products in SNAP as made for this exercise, please check section 8.1.

In this exercise:
• Variations in SWH, SLA, wind speed and Sigma0 will be investigated.
• We compare the track used in the previous exercises of OCEA06 Training Kit collected in the
same region 27 days before the event, with one acquired during the typhoon event.
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If you currently have a workspace loaded, delete it as indicated in section 7.3.1 and Create a New
Workspace as in section 7.2.1.
Go to the Workspace Elements panel
→ Datasets. Click on “Create New
Dataset”
. Name the dataset as
“Exercise_4”. Then in order to load the
required track, click on “Add Files” .
Select the track downloaded from the
EUMETSAT Data Hub from the folder:
/shared/Training/OCEA07_Oceanography_TutorialKit/Original/S3_data
“S3A_SR_2_WAT____20180710T013336_20180710T021747_20180804T173801_2651_033_174____
__MAR_O_NT_003”.
Select the “standard_measurement.nc” file and click “Open”.

0
The track orbit will appear in red on the BRAT map.

Create a filter in the following region (near Taiwan) using the instructions indicated at the section 7.6
of OCEA06 Training Kit and include the area below:
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Now select the filter you have created, plot the 4 variables shown below and then activate the “Split
plots” function
by following the instructions indicated in section 7.4.2 of OCEA06 Training Kit for
Advanced Operation. Drag from the “Fields” field the variables and
drop them in the “Data Expressions” field. Use:
•
•

in X: lat_01 (degrees north)
in Data: swh_ocean_01_ku (m)
wind_speed_alt_01_ku (m/s)
sig0_ocean_01_ku (dB)
ssha_01_ku (m)

By re-doing the same filtering/operations considering the track in which the typhoon is present (see
section 7.3.4 to delete the previous and import a new track) and comparing, we have:
SWH (Top: No typhoon, Bottom: Typhoon)
The track intersects the typhoon at a latitude of around 25 degrees (not crossing the eye of the storm).
Please note that the latitude interval may varies according to the selected latitude filter.
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Wind speed (Top: No typhoon, Bottom: Typhoon):
The track intersects the typhoon at a latitude of around 25 degrees (not crossing the eye of the storm).
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NOTE 7: SWH may reach very high values during a typhoon event. The wind, sigma0 and sea level
anomaly result impacted as well.

Exercise n. 5 – Global and Mean Sea Level Anomaly
7.5.1

Sea level anomalies
Sea level anomalies are sea surface heights
(SSH) with respect to the mean sea surface
(MSS). It is not to be confused with what is
usually called “Mean Sea Level” (MSL), which
is a measure of the sea level variations over
time.
They contribute to the calculation of the
Absolute Dynamic Topography (ADT), which
is given by the sum of Sea Level Anomaly
(SLA) and Mean Dynamic Topography (MDT).
Usage: Sea level anomaly data derived from
satellite altimetry can be analyzed to
investigate mesoscale eddies.
The mesoscale variability generally refers to
ocean signals with space scales of 50-500 km
and time scales of 10-100 days. The Kuroshio
region is one of the most active regions of
eddies.

As an example, below are depicted the El Niño
/ La Niña maps: Monthly averages maps of Sea Level Anomalies (in cm) on November each year since
1993, over the Equatorial Pacific from the El Niño Bulletin.
La Niña is a climate pattern that describes the cooling of surface ocean waters along the tropical west
coast of South America. La Nina is considered to be the counterpart to El Niño, which is characterized
by unusually warm ocean temperatures in the equatorial region of the Pacific Ocean.
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7.5.2 Global Sea Level Anomaly
To run this exercise, please delete the current workspace, create a new one, name it Webinar_2_sla
and then create a new dataset including all the data tracks from the folder: /shared/Training/OCEA07
_Oceanography_TutorialKit/Original/CMEMS_data/Sentinel-3_GLO
Name it “Datasets_2” and click on the arrow at its left to view all the loaded data tracks.

As the CMEMS data template is not memorised in BRAT, the imported tracks will not be displayed on
the BRAT map. However, products can be processed.
Go to Operations tab → Advanced, click on the Map icon
and run the following operation to create
a map. Drag from the “Fields” field the variables and drop them in the “Data Expressions” field. Use:
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•
•
•

in Lon: longitude (degrees_east)
in Lat: latitude (degrees_north)
in Data: sla_filtered (m)

Make sure that under “Operation” and “Dataset” you
have selected the proper ones that refer to the data
you are working with.
Click on
window.

and then on “Yes” at the pop-up

It will take a few minutes and once the processing is
completed, the following resulting Map will appear (go
to “Data Options” tab):

At “Colour Range”, set as min: -0.1 and max: 0.1 (double click in each field, write the value and press
Enter so that the value will be accepted). You can Reset the values or change the Colour Table/ramp.

36

BRAT allows users to apply filters for smoothing
(to filter out high frequency features by
reducing the resolution of the native product).
A Loess filter is a low-pass filter mostly used for
smoothing. Loess cut-off values are discussed
in the BRAT user manual.
Here is an example with the LOESS_SMOOTH
filter selected as reported below after having
highlighted the sla_filtered and it is evident
under Data.
Click on

and once LOESS_SMOOTH has

been selected, click on
the fields as the figure below:

and modify

Execute again the operation and the following Map will be produced (set min and max values again):

The smooth version is available and can be saved using the button

at the Processing folder. You

can also visualize the result in 3D view by clicking on the “3D Display 3D view” icon

.

7.5.3 Monthly mean Sea Level Anomaly
The same exercise can be repeated with the CMEMS dataset available in the folder
@/shared/Training/OCEA07_Oceanography_TutorialKit/Original/CMEMS_data/Sentinel-3/Data.
In this case, data are grouped per month. By importing one month of data at a time, the SLA can be
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calculated for the Mediterranean CMEMS dataset and the statistics evaluated . It follows that it is
possible to create an animation by using the 12 figures obtained as outputs of the 12 operations (one
per month maintaining the same colour bar interval, see the video of the Webinar). As an example, for
January 2017 data:

By calculating the statistics

we can evaluate the mean sea level anomaly variation month by month:

NOTE 8: BRAT statistics can be used to evaluate the average values of points in one track (e.g. over
rivers/lakes or in the coastal zone) or in a dataset (gridded products or datasets composed many along
track files as the CMEMS ones).
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Exercise n. 6 – Geostrophic currents & Current Speed
7.6.1 Mean Sea Surface
Mean Sea Surfaces (MSS) are essentially satellite altimetry by-products. MSS are used to obtain the
sea level anomalies by subtracting SSH-MSS. The mean sea surface is the displacement of the sea
surface relative to a mathematical model of the earth and it closely follows the geoid.
MSS amplitudes ranges between +/- 100 meters. To produce them, along-track mean profiles from
different inter-calibrated missions are merged using optimal interpolation techniques. The resulting
gridded field is the so-called altimetric Mean Sea Surface (MSS). Two examples of MSS are reported
below:

7.6.2 Mean Dynamic Topography
If the oceans were static and not affected by external influence as for example wind, temperature and
air pressure, then Mean Sea Surface (MSS) and the Geoid would be the same surfaces. However, there
are steady currents in the ocean, driven by winds and atmospheric heating and cooling, which give rise
to differences in sea level around the world. These local differences between the Geoid and MSS are
described by the Dynamic Ocean Topography (DOT). The DOT values range between (approximately) 2.5m and +1.2 m. Recent MDTs and MSS are calculated using 20 years of altimetry data.
A Mean Dynamic Topography (MDT = MSS − geoid) is required to estimate the mean (time-invariant)
transport in the ocean.
From the MDT scientists calculate the components and speed of time-invariant ocean geostrophic
currents.
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7.6.3 Geostrophic currents
Definition: The absolute dynamic topography is defined as the sea surface height above the geoid and
is obtained by summing sea level anomaly (SLA) and mean dynamic topography (MDT):
ADT = MDT + SLA
The MSS used to generate the SLAs must be defined over the same averaging period as the MDT.

Credit: CLS

For this exercise use the ADT_from_MDT_AVISO_CLS_2009_plus_SLCCI_v2.nc in the folder:
/shared/Training/OCEA07_Oceanography_TutorialKit/Original/SLCCI_Data
The provided ADT is used to evaluate the instantaneous total surface geostrophic currents using the
typical geostrophic equations:

and allows the calculation of the corresponding total surface geostrophic speed:
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→ where us and vs are the components of the surface geostrophic velocity, f is the Coriolis parameter,
g is the acceleration due to gravity, h is the ADT and x and y are distances along zonal and meridional
directions, respectively.
The principle of geostrophy is useful to oceanographers because it allows them to infer ocean currents
from measurements of the sea surface height.
In BRAT, please create a New Workspace, go to Datasets tab and create a New Dataset, Add the
product mentioned above, then go to Operations tab → Advanced → Create operation and create
the following Map operation:

•
•

1: Select Map in order to map the data Field ‘dt’ (=ADT) as in the previous exercises and create
an empty expression named U [m/s].
2-5: Highlight U and select the algorithms icon (2) to insert the BRAT algorithm
BratAlgoGeosVelGridU (3) and click OK (4). The algorithm will appear under the Data field.

•

Modify the default expression to exec("BratAlgoGeosVelGridU", %{lat}, %{lon}, dt, 2) (5).

•

Equator_Margin = 2 degrees (latitude North and South below which the computation will not
be done, to take into account the lack of Coriolis force at the Equator).

•

6-7: Check the correctness of the formula with ✓ (if it is correct, you will see at the Output →
Log → “Data expression OK”, if not, an invalid expression warning window will pop-up). Then
save it with ε.

Then repeat the same steps (1-7) and create another expression where you will set the parameters as
following:
41

•
•

1: Select Map in order to map the data Field ‘dt’ (=ADT) as in the previous exercises and create
another empty expression named V [m/s].
2-5: Highlight V and select the algorithms icon (2) to insert the BRAT algorithm
BratAlgoGeosVelGridV (3) and click OK (4). The algorithm will appear under the Data field.

•

Modify the default expression to exec("BratAlgoGeosVelGridV", %{lat}, %{lon}, dt, 2) (5).

•

6-7: Check the correctness of the formula with ✓ and save it with ε.

To conclude, set the vector plot components for U & V as follows:
“U” Display properties: Select “Vector Plot Component” and “East Component”
“V” Display properties: Select “Vector Plot Component” and “North Component”
NOTE 9: If the “Display properties” window is inactive, make sure that you have inserted in the Lon and
Lat the values as indicated below in the blue rectangle.

Please keep under Data the dt, U and V (1) and
add the following selecting criteria (optional):
• 2: Selection criteria (optional): Set Units = deg
• 3: Write the following expression: ((lon < 314)
& (lon > 256)) & ((lat > 15) & (lat < 44))
• 4-5: Check the correctness of the formula
with ✓ and save it with ε
Then execute the operation by clicking on
and then on “Yes” at the pop-up
window.
The following window-map will appear. Go to
Data Options tab (6). Two maps are selectable
now: dt [m], as before, and U/V [m/s] (7).
Select the dt[m] and check under Contours → “Show”

, to show the contours (8):
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6
Then, switch to the U/V Map and put e.g. Vector Scale = 4. You can try with 1 or 1.5 a well as with
other values. Zoom in to better see the currents:

7.6.4

Current Speed
Delete the previous operation including
expressions for U, V & dt and close the previous
Maps before executing.
Create a new operation and copy and paste U
and V formulas into a new expression to be
named “Speed” [m/s] in order to obtain “Wadt”:

Data: sqrt(exec(“BratAlgoGeosVelGridV”, %{lat},
%{lon}, dt, 2)^2+exec(“BratAlgoGeosVelGridU”,
%{lat}, %{lon}, dt, 2)^2)
Execute and repeat the last steps as before:
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After having set the maximum colour bar value to 1.7m/s, the Gulf current is clearly revealed along
with its speed.

8

Extra Steps
SNAP processing of Sentinel-3 products (see section 7.4) – Data download – ESA SciHUB

For those interested in using SNAP, the OLCI product can be downloaded from the Copernicus Open
Access Hub using the online interface (Applications → Network → Web Browser or click the link
below).
Go to https://scihub.copernicus.eu/

Go to “Open Hub”. If you do not have an account please sign up in the upper right corner, fill in the
details and click register.
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You will receive a confirmation email on the e-mail address you have specified: open the email and
click on the link to finalize the registration.
Once your account is activated – or if you already have an account – log in.
-

Switch the rectangle drawing mode to pan mode by clicking on the icon in the upper right
corner of the map (Green arrow).
Use the left mouse button to move over the globe and draw the rectangle shown below by
holding the right mouse button
Open the search menu by clicking at the left of the search bar ( ),
Specify the following parameters and press the search button ( ):

Sort by: Sensing Date
Sensing period: From 2018/07/10 to 2018/07/10 (1 day)
Check Mission: Sentinel-3
Product type: OL_1_EFR___
Timeliness: “Non Time Critical”
Instrument: OLCI
Product Level: “L1”
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Download the following product by clicking the download icon

.

S3A_OL_1_EFR___20180710T01512_20180710T015312_20180711T060534_0179_033_174_2520_LN1_O_NT_002

A quick look at the product, to verify the typhoon presence, is available by clicking on the icon

.

Once the product is downloaded (@/home/rus/Downloads), copy it to the following path and unzip it
(right click → Extract Here)
Path: /shared/Training/OCEA07_Oceanography_TutorialKit/Original/OLCI
Later the product can be opened in SNAP (open the xfdumanifest.xml file).
Launch SNAP (icon on desktop ). When the SNAP window opens click Open product
and navigate
to /shared/Training/OCEA07_Oceanography_TutorialKit/Original/OLCI, open the folder of the
Sentinel-3 OLCI product and select the file xfdumanifest.xml. Then, click OK.
The product will appear as at the following window.
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Then re-project in UTM/WGS 84 and save it in GeoTiff format using the following command:
Go to Raster → Geometric Operations → Reprojection.
In the I/O Parameters tab set the following:
As (Source): S3A_OL_1_EFR___20180710T01512_20180710T015312_20180711T060534_0179_033_174_2520_LN1_O_NT_002
As (Target): S3A_OL_1_EFR___20180710T01512_20180710T015312_reprojected
As Directory: /shared/Training/OCEA07_Oceanography_TutorialKit/Processing
In the Processing Parameters tab set the following:
Select Custom CRS and at Projection: UTM / WGS 84 (Automatic).

Click Run. Once the GeoTIFF is created, go to File → Export → Other → View as Google Earth KMZ so
that it can be opened in Google Earth (a .kml including the position of the estimates in the L2 WAT
product can be also prepared to support the combined analysis, or Sentinel-3 tracks in .kml
format from: https://sentinel.esa.int/web/sentinel/missions/sentinel-3/satellite-description/orbit
can be used).
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Download files from VM
In your VM, press Ctrl+Alt+Shift.
A pop-up window will appear on the left side of the screen. Click on the bar below Devices, navigate
to the folders you have saved the files you want to download and double click on them. The
downloading process to your local computer will start automatically.

THANK YOU FOR FOLLOWING THE EXERCISE!
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Further reading and resources
•

Sentinel-3 Altimetry User Guide
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-3-altimetry

•

Sentinel-3 Altimetry Technical Guide
https://sentinel.esa.int/web/sentinel/technical-guides/sentinel-3-altimetry

•
•

R. K. Raney, “The delay/Doppler radar altimeter,” IEEE Trans. Geosci. Remote Sens., vol. 36,
no. 5, pp. 1578–1588, Sep. 1998. DOI: 10.1109/36.718861
“Fully Focused SAR Altimetry: Theory And Applications” by Egido And Smith (2016) Doi:
10.1109/Tgrs.2016.2607122

FOLLOW US!!!
@RUS-Copernicus
RUS-Copernicus
RUS-Copernicus
RUS Copernicus Training
RUS-Copernicus website
website
RUS-Copernicus Training website
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